Bug 729332 - matahari-qmf-service-cli specifies two -P, displays error
Summary: matahari-qmf-service-cli specifies two -P, displays error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andrew Beekhof
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 14:35 UTC by Dave Johnson
Modified: 2011-12-06 11:39 UTC (History)
3 users (show)

Fixed In Version: matahari-0.4.2-7.el6
Doc Type: Bug Fix
Doc Text:
No description required
Clone Of:
Environment:
Last Closed: 2011-12-06 11:39:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-09 14:35:35 UTC
Description of problem:
============================
Command displays error on two '-P'

[root@agent sbin]# /usr/sbin/matahari-qmf-service-cli -help
int mh_add_option(int, int, const char*, const char*, void*, int (*)(int, const char*, const char*, void*)): Replacing '-P|--provider' with '-P|--password'
Usage:  matahari-service-consoled <options>


Version-Release number of selected component (if applicable):
===============================================================
matahari-service-0.4.2-2.el6.x86_64

How reproducible:
=================
100%

Steps to Reproduce:
=========================
1.  Install matahari broker and service agent
2.  run '/usr/sbin/matahari-qmf-service-cli -help'

Comment 2 Dave Johnson 2011-08-09 15:17:55 UTC
while you are at it, fix the misspelling of purple roses? :)

-u | --username value   username to use for authentication purproses.
-P | --password value   password to use for authentication purproses.
-s | --service value    service name to use for authentication purproses.

Comment 5 Dave Johnson 2011-08-16 23:04:04 UTC
More errors and purposes is still misspelled in v0.4.2-6....

[root@dell-pe2900-01 sbin]# ./matahari-qmf-service-cli -h
mh_add_option: Replacing '-a|--agent' with '-a|--action'
mh_add_option: Replacing '-s|--standard' with '-s|--service'
Usage:	matahari-service-consoled <options>

Common options:
	-h | --help             print this help message.
	-b | --broker value     specify broker host name..
	-p | --port value       specify broker port.
	-u | --username value   username to use for authentication purproses.
	-P | --password value   password to use for authentication purproses.
	-s | --service value    service name to use for authentication purproses.
	-r | --reconnect value  attempt to reconnect on failure.

Custom options:
	-A | --api	 Resources|Services
	-H | --host-dns	 Host DNS name
	-S | --provider	  (Resources API only)
	-U | --host-uuid	 Host UUID
	-a | --action	 Action to perform
	-i | --interval	 (Resources API only)
	-n | --name	 Name of a resource
	-t | --timeout	 Time to wait, in seconds, for the action to complete
[root@dell-pe2900-01 sbin]# rpm -qa matahari-consoles
matahari-consoles-0.4.2-6.el6.x86_64

Comment 6 Andrew Beekhof 2011-08-17 01:24:35 UTC
A related patch has been committed upstream: https://github.com/beekhof/matahari/commit/1202bac

Comment 7 Andrew Beekhof 2011-08-17 01:26:18 UTC
# linux.build/src/service/matahari-qmf-service-cli -h
Usage:	matahari-qmf-service-clid <options>

Common connection options:
	-h | --help             print this help message.
	-b | --broker value     specify broker host name..
	-p | --port value       specify broker port.
	-u | --username value   username to use for authentication purposes.
	-P | --password value   password to use for authentication purposes.
	-s | --service value    service name to use for authentication purposes.
	-r | --reconnect value  attempt to reconnect on failure.

Custom options:
	-A | --agent     	(Resources API only)
	-H | --host-dns  	Host DNS name
	-J | --provider  	(Resources API only)
	-N | --name      	Name of a resource
	-S | --standard  	lsb|ocf|windows (Resources API only)
	-T | --api-type  	Resources|Services
	-U | --host-uuid 	Host UUID
	-a | --action    	Action to perform
	-i | --interval  	(Resources API only)
	-t | --timeout   	Time to wait, in seconds, for the action to complete

Comment 9 Dave Johnson 2011-08-19 20:00:02 UTC
good 2 go in v0.4.2-7

[root@hp-bl260cg5-01 matahari]# matahari-qmf-service-cli -h
Usage:	matahari-qmf-service-clid <options>

Common connection options:
	-h | --help             print this help message.
	-b | --broker value     specify broker host name..
	-p | --port value       specify broker port.
	-u | --username value   username to use for authentication purposes.
	-P | --password value   password to use for authentication purposes.
	-s | --service value    service name to use for authentication purposes.
	-r | --reconnect value  attempt to reconnect on failure.

Custom options:
	-A | --agent     	(Resources API only)
	-H | --host-dns  	Host DNS name
	-J | --provider  	(Resources API only)
	-N | --name      	Name of a resource
	-S | --standard  	lsb|ocf|windows (Resources API only)
	-T | --api-type  	Resources|Services
	-U | --host-uuid 	Host UUID
	-a | --action    	Action to perform
	-i | --interval  	(Resources API only)
	-t | --timeout   	Time to wait, in seconds, for the action to complete
[root@hp-bl260cg5-01 matahari]#

Comment 10 Russell Bryant 2011-11-16 21:36:44 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required

Comment 11 errata-xmlrpc 2011-12-06 11:39:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.