Bug 729346 - SIGSEGV on s390x arch.
Summary: SIGSEGV on s390x arch.
Keywords:
Status: CLOSED DUPLICATE of bug 584300
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openmotif
Version: 6.2
Hardware: s390x
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Thomas Woerner
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 16:07 UTC by Lukas Zachar
Modified: 2011-08-15 09:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-10 11:28:49 UTC


Attachments (Terms of Use)
Fix for regression (408 bytes, patch)
2011-08-09 18:25 UTC, Thomas Woerner
no flags Details | Diff

Comment 2 Thomas Woerner 2011-08-09 18:25:23 UTC
Created attachment 517461 [details]
Fix for regression

A call to _XmXftDrawCreate has been added to LabelG.c, but the header file that contains the function definition was not included.

This simple fix adds the missing include for XmRenderTI.h to LabelG.c.

Comment 3 Thomas Woerner 2011-08-10 11:28:49 UTC
The upstream fix for bz#584300 introduced the regression. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 584300 ***

Comment 4 Lukas Zachar 2011-08-15 09:34:22 UTC
The additional fix solved the issue - no SIGSEGV on s390x anymore.


Note You need to log in before you can comment on or make changes to this bug.