Bug 729450 - Lots of: block I/O error in device 'virtio0': Input/output error (5)
Summary: Lots of: block I/O error in device 'virtio0': Input/output error (5)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Minchan Kim
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-08-09 18:59 UTC by Richard W.M. Jones
Modified: 2014-07-25 04:16 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-29 12:27:14 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2011-08-09 18:59:43 UTC
Description of problem:

When testing libguestfs we get many errors that say:

block I/O error in device 'virtio0': Input/output error (5)
block I/O error in device 'virtio1': Input/output error (5)
block I/O error in device 'virtio0': Input/output error (5)
block I/O error in device 'virtio0': Input/output error (5)
block I/O error in device 'virtio1': Input/output error (5)
block I/O error in device 'virtio0': Input/output error (5)
block I/O error in device 'virtio0': Input/output error (5)
block I/O error in device 'virtio1': Input/output error (5)
block I/O error in device 'virtio0': Input/output error (5)
block I/O error in device 'virtio1': Input/output error (5)
block I/O error in device 'virtio0': Input/output error (5)

http://download.devel.redhat.com/brewroot/work/tasks/4454/3544454/build.log

The errors appear not to affect the performance of the guest.
The reason for this is not known.

Version-Release number of selected component (if applicable):

qemu-kvm 2:0.12.1.2-2.160.el6_1.6.x86_64
0:kernel-2.6.32-183.el6.x86_64

How reproducible:

?

Steps to Reproduce:
1. Run a virtio Linux guest on qemu-kvm.
2.
3.
  
Actual results:

Lots of strange block I/O errors.

Expected results:

No errors.

Additional info:

Comment 2 chellwig@redhat.com 2011-08-12 00:13:54 UTC
Can youshow a proper testcase without that guestfish stuff?

Comment 3 Richard W.M. Jones 2011-08-12 07:36:04 UTC
The full command I ran is listed right there in the build log
I linked to.

/usr/libexec/qemu-kvm \
    -drive file=debian.img.tmp,cache=off,format=raw,if=virtio \
    -nodefconfig \
    -nodefaults \
    -nographic \
    -m 500 \
    -no-reboot \
    -device virtio-serial \
    -serial stdio \
    -chardev socket,path=/tmp/libguestfsoaZ5Tj/guestfsd.sock,id=channel0 \
    -device virtserialport,chardev=channel0,name=org.libguestfs.channel.0 \
    -kernel /tmp/.guestfs-250/kernel.30186 \
    -initrd /tmp/.guestfs-250/initrd.30186 \
    -append 'panic=1 console=ttyS0 udevtimeout=300 noapic acpi=off printk.time=1 cgroup_disable=memory selinux=0 guestfs_verbose=1 TERM=xterm ' \
    -drive file=/tmp/.guestfs-250/root.30186,snapshot=on,if=virtio,cache=unsafe

Comment 4 Pavel Holica 2011-08-12 12:02:28 UTC
Hello, I've hit this on RHEL6.2-20110812.n.0 (guest) running on RHEL6.1 GA (host).

My command is:
qemu-kvm -monitor stdio -m 1024 -net tap -net nic,model=virtio -drive if=virtio,file=/srv/images/system1,boot=on -cdrom boot.iso -boot once=d

Comment 5 Pavel Holica 2011-08-12 12:02:50 UTC
And both systems were x86_64.

Comment 6 Richard W.M. Jones 2011-08-12 12:07:57 UTC
Pavel, do these errors cause problems?  For me, the guest appears
to continue running regardless.  There doesn't *appear* to be any
actual disk corruption or stoppage, although the messages in 'dmesg'
certainly look worrying.

Comment 7 Pavel Holica 2011-08-12 12:19:31 UTC
Can't see any real problem too, both systems seems to run fine for me.

Comment 9 Chao Yang 2011-11-17 12:25:43 UTC
I have reproduced this issue with 2.6.32-131.21.1.el6.x86_64, qemu-kvm-0.12.1.2-2.160.el6_1.9.x86_64, lots of "block I/O error in device 'virtio0': Input/output error (5)" pops up when trying to boot a virtio-blk-pci image, but these errors seems wouldn't cause any corruption. 

Adding werror=stop to same cli, guest won't stop on block I/O error. But guest will stop on block I/O error if appending * rerror=stop*  to same cli. So, it is a read error from this point of view. Hope this helps.

Comment 10 Chao Yang 2011-11-17 12:42:17 UTC
Additional info:
Can't reproduce this issue on rhel6.2 with same cli with 2.6.32-216.el6.x86_64, qemu-kvm-0.12.1.2-2.209.el6.x86_64

Comment 11 Minchan Kim 2011-11-29 11:17:51 UTC
chayang,
Then, could you close this bug?

Comment 12 Chao Yang 2011-11-29 12:27:14 UTC
(In reply to comment #11)
> chayang,
> Then, could you close this bug?

Sure,
Closing this bug as CURRENTRELEASE due to Comment # 9,10


Note You need to log in before you can comment on or make changes to this bug.