Bug 72947 - gdm ja date format is ugly
gdm ja date format is ugly
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: gdm (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-29 08:40 EDT by Jens Petersen
Modified: 2007-04-18 12:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-05 11:51:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdm ja.po (106.54 KB, patch)
2002-08-30 06:42 EDT, Akira TAGOH
no flags Details | Diff
gdm ja.po (106.54 KB, text/plain)
2002-08-30 06:44 EDT, Akira TAGOH
no flags Details

  None (edit)
Description Jens Petersen 2002-08-29 08:40:41 EDT
Description of Problem:
The format of the ja date string translation should be changed
so that the date is ordered in a intelligible way.

Version-Release number of selected component (if applicable):
2.4.0.7-7

How Reproducible:
every time

Steps to Reproduce:
1. Start gdm in ja locale

Actual Results:
The same date string "%a %b %d, %I:%M %p" as for English is used.

Expected Results:
"%x(%a) %p%l:%M" say would be better.

Additional Information:
I don't know about zh and ko.
Comment 1 Akira TAGOH 2002-08-30 03:50:09 EDT
If %x is specified, no need to contains '(%a)'. %x means *without time* you
know. it includes a weekday name.
Comment 2 Jens Petersen 2002-08-30 05:45:23 EDT
Ok, my string is based on date(1).  glibc does something different?
Comment 3 Akira TAGOH 2002-08-30 05:58:13 EDT
Look at the source. and man 3 strfime.
Comment 4 Akira TAGOH 2002-08-30 05:58:57 EDT
s/strfime/strftime/
Comment 5 Akira TAGOH 2002-08-30 06:11:33 EDT
Hmm, if we respect meaning of %b, '%m/%d(%a) %p %I:%M' is better, I think.
because %x contains a year. also it definitely abbreviates a month and a day for
Japanese.
Comment 6 Akira TAGOH 2002-08-30 06:13:14 EDT
Hmm, I've made a lot of typo... I mean 'it doesn't definitely abbreviates a
month and a day for Japanese.'
Comment 7 Akira TAGOH 2002-08-30 06:42:54 EDT
Created attachment 73934 [details]
gdm ja.po
Comment 8 Akira TAGOH 2002-08-30 06:44:14 EDT
Created attachment 73935 [details]
gdm ja.po
Comment 9 Akira TAGOH 2002-08-30 06:49:44 EDT
could you use an attached ja.po?
Comment 10 Havoc Pennington 2002-08-30 13:24:59 EDT
We will try. there's only a few hours left though really.
Comment 11 Havoc Pennington 2002-08-31 00:59:59 EDT
Putting in -10
Comment 12 Jens Petersen 2002-09-03 01:52:16 EDT
Afraid with gdm-2.4.0.7-10, I still see "%a %b %d, %I:%M %p" output
not "%m/%d (%a) %p %I:%M" in a Japanese locale.
Comment 13 Akira TAGOH 2002-09-05 10:30:27 EDT
Havoc, you had to copy gdm-ja.po as ja.po on %%setup :(
I did in 2.4.0.7-12.
Comment 14 Havoc Pennington 2002-09-05 11:51:35 EDT
Thanks tagoh, sorry about that.
Comment 15 Jay Turner 2002-09-05 13:48:28 EDT
So, looks like this is taken care of.  Closing out.  Please reopen if the date
string is still formatted incorrectly.
Comment 16 Jens Petersen 2002-09-06 03:46:15 EDT
Yep, looks good to me in gdm-2.4.0.7-13.

Note You need to log in before you can comment on or make changes to this bug.