Bug 729493 - Fedora 16 Alpha RC3 / Anaconda crash at the bootloader installation step
Summary: Fedora 16 Alpha RC3 / Anaconda crash at the bootloader installation step
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-09 22:14 UTC by Othman Madjoudj
Modified: 2011-08-10 11:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-10 11:25:50 UTC


Attachments (Terms of Use)
anaconda log (22.86 KB, text/plain)
2011-08-09 22:15 UTC, Othman Madjoudj
no flags Details
anaconda traceback (321.24 KB, text/plain)
2011-08-09 22:16 UTC, Othman Madjoudj
no flags Details

Description Othman Madjoudj 2011-08-09 22:14:11 UTC
Description of problem:

When I installed Fedora 16 Alpha RC3 Anaconda crash at bootloader installation step (at the end of installation)


Steps to Reproduce:
1. Install F16 Alpha RC3 via PXE Boot
2. Use Autopart without LVM
3. Choose root password etc...
4. Wait the installation
  
Actual results:
Anaconda crash when it try to install bootloader and the system is not bootable

Expected results:
Anaconda install bootloader and the system boot correctly

Additional info:

When I installed F16 Alpha RC1 this bug didn't happen.

Comment 1 Othman Madjoudj 2011-08-09 22:15:18 UTC
Created attachment 517498 [details]
anaconda log

Comment 2 Othman Madjoudj 2011-08-09 22:16:17 UTC
Created attachment 517500 [details]
anaconda traceback

Comment 3 David Lehman 2011-08-09 22:29:43 UTC
This is due to package installation errors:

21:53:12 Installing grub2-1.99-0.2.fc16.x86_64
error: grub2-1:1.99-0.2.fc16.x86_64: install failed


It appears that the transaction was, to some extent, aborted midway through.

Comment 4 Othman Madjoudj 2011-08-09 22:35:05 UTC
(In reply to comment #3)
> This is due to package installation errors:
> 
> 21:53:12 Installing grub2-1.99-0.2.fc16.x86_64
> error: grub2-1:1.99-0.2.fc16.x86_64: install failed
> 
> 
> It appears that the transaction was, to some extent, aborted midway through.

Is this reproducible or it's just a coincidence (issues with network or mirror)

Comment 5 Adam Williamson 2011-08-09 22:50:26 UTC
I think that's what we'd like to ask you =) can you try it again? I don't see anything that changed from rc1 to rc3 which would be likely to cause this. I've done an install here (live install) that worked.

Comment 6 He Rui 2011-08-10 06:52:55 UTC
I virt-installed RC3 according you steps but didn't reproduce your issue. The Grub2 version I installed is also grub2-1.99-0.2.fc16.x86_64.

Comment 7 Othman Madjoudj 2011-08-10 11:25:50 UTC
It's not reproducible, it might be a network issue from me.


Note You need to log in before you can comment on or make changes to this bug.