Bug 729561 - Cannot discover iSCSI device by using emulex iSCSI HBA
Summary: Cannot discover iSCSI device by using emulex iSCSI HBA
Keywords:
Status: CLOSED DUPLICATE of bug 520111
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Mike Burns
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 07:38 UTC by Guohua Ouyang
Modified: 2011-08-10 09:12 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-10 08:41:15 UTC


Attachments (Terms of Use)
dmesg + messages (23.33 KB, application/x-gzip)
2011-08-10 07:39 UTC, Guohua Ouyang
no flags Details

Description Guohua Ouyang 2011-08-10 07:38:12 UTC
Description of problem:
iSCSI devic is connected by emulex iSCSI HBA, boot with rhevh media cannot find iSCSI lun.
Tested with RHEL6 media, it can find iSCSI lun and installed rhel to it.

# lspci | grep Emulex
03:00.0 Ethernet controller: Emulex Corporation OneConnect 10Gb NIC (rev 02)
03:00.1 Ethernet controller: Emulex Corporation OneConnect 10Gb NIC (rev 02)
03:00.2 Mass storage controller: Emulex Corporation OneConnect 10Gb iSCSI Initiator (rev 02)
03:00.3 Mass storage controller: Emulex Corporation OneConnect 10Gb iSCSI Initiator (rev 02)


Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.11.el6

How reproducible:
Always.

Steps to reproduce:
1. Configure emulex iSCSI HBA correctly. .
2. boot with rhevh media.
3. Try to find iSCSI lun.

Actual results:
Cannot find iSCSI device during rhevh installation.

Expected results:
Can find iSCSI device during rhevh installation. .

Comment 1 Guohua Ouyang 2011-08-10 07:39:15 UTC
Created attachment 517533 [details]
dmesg + messages

Comment 3 Alan Pevec 2011-08-10 08:41:15 UTC
19a2:0702 (kmod is be2iscsi) Mass storage controller: Emulex Corporation OneConnect 10Gb iSCSI Initiator is not a full HW HBA, it's iscsi off-load card and still requires iscsid on the Linux side.
Currently, rhevh doesn't support such disk for installation (it should still work for RHEV storage domain).

*** This bug has been marked as a duplicate of bug 520111 ***

Comment 4 Alan Pevec 2011-08-10 08:50:21 UTC
FYI after iscsid is started and iscsiadm -m fw -l iscsi disks showed up on rhevh

Comment 5 Alan Pevec 2011-08-10 09:03:33 UTC
FYI RHEL 6.1 setup on such iscsi disk has this in boot parameters:
ro root=/dev/mapper/vg_XXX-lv_root iscsi_firmware ip=eth2:dhcp ifname=eth2:XX:XX:XX:XX:XX:XX rd_LVM_LV=vg_XXX/lv_root rd_LVM_LV=vg_XXX/lv_swap

Comment 6 Alan Pevec 2011-08-10 09:12:02 UTC
And last FYI, RHEL /boot is also on iscsi, so boot access is provided via BIOS interface on the card:
#cat /boot/grub/device.map 
# this device map was generated by anaconda
(hd0)     /dev/mapper/mpathb

# multipath -ll
mpathb (1IET     00010001) dm-0 IET,VIRTUAL-DISK


Note You need to log in before you can comment on or make changes to this bug.