Bug 729587 - "=~" Does not work on RHEL6
Summary: "=~" Does not work on RHEL6
Keywords:
Status: CLOSED DUPLICATE of bug 558537
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bash
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Roman Rakus
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 09:23 UTC by Dimitar Yordanov
Modified: 2014-01-13 00:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-10 09:36:32 UTC


Attachments (Terms of Use)

Description Dimitar Yordanov 2011-08-10 09:23:02 UTC
Description of problem:
"=~" Does not work on RHEL6.

Version-Release number of selected component (if applicable):
bash-4.1.2-8.el6.x86_64

How reproducible:
100%

Steps to Reproduce:

 RHEL6 - bash-4.1.2-8.el6.x86_64

 #RHN_SERVER="xmlrpc.rhn.errata.stage.redhat.com"
 #[[ $RHN_SERVER  =~ ".*errata.stage.*" ]] && echo 'OK'
 #[[ $RHN_SERVER =~ 'xmlrpc.rhn.(errata.stage.)*redhat.com' ]]  && echo 'OK'



 RHEL5 - bash-3.2-32.el5

 #RHN_SERVER="xmlrpc.rhn.errata.stage.redhat.com"
 #[[ $RHN_SERVER  =~ ".*errata.stage.*" ]] && echo 'OK'
 OK

 #[[ $RHN_SERVER =~ 'xmlrpc.rhn.(errata.stage.)*redhat.com' ]]  && echo 'OK'
 OK
  
Actual results:
Different results on RHEL5 RHEL6

Expected results:
Works on RHEL5 and RHEL6

Additional info:

Comment 1 Roman Rakus 2011-08-10 09:36:32 UTC
Please see bug #558537, technical note. There was bug in previous versions of bash which is now fixed.

*** This bug has been marked as a duplicate of bug 558537 ***


Note You need to log in before you can comment on or make changes to this bug.