Bug 729642 - Failed to load session "gnome" because of missing metacity dependency
Failed to load session "gnome" because of missing metacity dependency
Status: CLOSED DUPLICATE of bug 746693
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-10 08:56 EDT by Mads Kiilerich
Modified: 2011-10-24 18:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 18:09:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2011-08-10 08:56:33 EDT
It seems like f16 gnome-session(?) has an invisible dependency to metacity.

If gnome shell fails and it wants to fall back to compatibility mode and metacity isn't available it will give a scary and unusable messagebox:
  Failed to load session "gnome"

dmesg gives a better hint:
gnome-session[1004]: WARNING: Session 'gnome' runnable check failed: Exited with code 1
gnome-session[1004]: WARNING: Unable to find default provider 'metacity' of required provider 'windowmanager'

I would prefer a rpm dependency to metacity so it didn't fail in the failure mode.

Alternatively, if the fallback mode really is optional then it should give some hint of the reason for the failure (that both shell and fallback failed, and especially why compatibility mode failed)

I realize that this is a consequence of the slightly hackish fallback mode and how the two modes in some ways are tightly integrated, and I don't know the best way to solve it. It did however show up for me like a bug, so I wanted to let you know and report it as such.
Comment 1 Bruce Jerrick 2011-08-18 13:36:33 EDT
I get the same thing with ol' F15.
-- Bruce Jerrick
Comment 2 Bruce Jerrick 2011-08-18 14:20:21 EDT
I don't think this is simple lack of metacity being installed.
With F15 I get the same thing with a custom spin that is a superset
of the F15 "Software Development" package set; also with a spin that
is essentially the same package set as my F14 installation.
AndI have seen a "metacity" process after the failure.
I don't see the problem in a stock F15 "Software Development"
installation or my F14 installation.
-- Bruce Jerrick
PS. Sorry if this is a bit garbled -- either this interface or
Bill's wonderful Internet Exploder is acting screwball.
Comment 3 Mads Kiilerich 2011-08-18 16:07:42 EDT
Bruce: I am sure there can be many reasons GNOME fails to load and this message is shown. My focus in this report is that it is unfortunate that metacity is mandatory for the expected behaviour but isn't a requirement at the rpm level. I suggest you file a separate issue in the bugtracker if you have a different issue.
Comment 4 Bruce Jerrick 2011-08-24 03:12:46 EDT
Mea culpa (that's Latin for "oops").
It turns out that I got this error under F15 because I was inadvertently
using F14 notification-daemon-0.5.0-1.fc14 .  Updating to F15 (core)
notification-daemon-0.7.1-1.fc15 fixed the problem.
So there should be a suitable Requires in gnome-session . 
In any case, the only error messages I got were exactly those mentioned
in the Description above, which is probably sub-optimal.
-- Bruce
Comment 5 Matthias Clasen 2011-10-24 18:09:44 EDT

*** This bug has been marked as a duplicate of bug 746693 ***

Note You need to log in before you can comment on or make changes to this bug.