Bug 729643 - virt-install fails with TypeError when initrd-inject is used
Summary: virt-install fails with TypeError when initrd-inject is used
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst
Version: 6.2
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-10 12:57 UTC by Richard Marko
Modified: 2016-02-01 02:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2011-12-06 16:17:15 UTC


Attachments (Terms of Use)
output of virt-install (3.60 KB, text/plain)
2011-08-10 12:57 UTC, Richard Marko
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1643 normal SHIPPED_LIVE python-virtinst bug fix and enhancement update 2011-12-06 00:50:36 UTC

Description Richard Marko 2011-08-10 12:57:27 UTC
Created attachment 517596 [details]
output of virt-install

Description of problem:
Running following command results in traceback.

virt-install --debug --name "VM" --ram "4196" --location "http://download.fedoraproject.org/pub/fedora/linux/releases/15/Fedora/x86_64/os/" --disk path=$DISK --initrd-inject=./anaconda-ks.cfg --extra-args "ks=file:/anaconda-ks.cfg"


Version-Release number of selected component (if applicable):
virtinst 0.600.0-2.el6, python 2.6.6-25.el6

How reproducible:
Always

Actual results:
TypeError: coercing to Unicode: need string or buffer, NoneType found

Expected results:
VM installed

Additional info:
Works fine on 6.1 (virtinst 0.500.5-3.el6, python 2.6.6-20.el6)

Comment 2 Cole Robinson 2011-08-23 19:53:45 UTC
Thanks for the report, fixed upstream:

http://git.fedorahosted.org/git?p=python-virtinst.git;a=commit;h=b7054426336929abb0ab0d822ad208a11d418904

Comment 3 Cole Robinson 2011-08-30 19:08:49 UTC
Fixed in python-virtinst-0.600.0-3.el6

Comment 5 Huming Jiang 2011-09-02 06:30:23 UTC
Reproduced with the following components:
libvirt-0.9.4-7.el6.x86_64
python-virtinst-0.600.0-2.el6.noarch

Verified with the following components:
libvirt-0.9.4-7.el6.x86_64
python-virtinst-0.600.0-3.el6.noarch
kernel-2.6.32-191.el6.x86_64
qemu-kvm-0.12.1.2-2.184.el6.x86_64
virt-manager-0.9.0-6.el6.x86_64

Steps:

   1. virt-install --debug -n vm -r 1024 -l http://download.englab.nay.redhat.com/pub/rhel/released/RHEL-6/6.1/Server/x86_64/os/ --disk path=/var/lib/libvirt/images/vm.img,size=5 --initrd-inject=/opt/ks-aj-RHEL6u1-Server-x64-2.6.32-131.0.15-qemu-kvm-0.12.1.2-2.160.el6-libvirt-0.8.7-18.el6-minimal-released.cfg --extra-args ks=http://home.englab.nay.redhat.com/~nzhang/http/ks-rhel6u1-x86_64.cfg
      ...
      (The guest will be automatically installed with no error.)

So move the status of this bug to verified.

Comment 6 Cole Robinson 2011-11-07 16:54:23 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 7 errata-xmlrpc 2011-12-06 16:17:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1643.html


Note You need to log in before you can comment on or make changes to this bug.