Bug 729716 - Can select more spares than raid partitions available
Can select more spares than raid partitions available
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ales Kozumplik
Release Test Team
patch
:
Depends On: 700804
Blocks: 670159 705163
  Show dependency treegraph
 
Reported: 2011-08-10 11:40 EDT by Alexander Todorov
Modified: 2014-09-30 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-13.21.128-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 700804
Environment:
Last Closed: 2011-12-06 05:40:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2011-08-10 11:40:11 EDT
+++ This bug was initially created as a clone of Bug #700804 +++

Created attachment 495774 [details]
"Numer of spares" is disabled

Description of problem:
When trying to create a RAID device with some spare members, anaconda doesn't allow to change the "Number of spares" field. (see attached screenshot).

To be able to change the number of spares, user has to change the "RAID Level" field first (RAID1 to RAID5 and then back to RAID1). After this step, user is able to modify the spares field.

Version-Release number of selected component (if applicable):
RHEL6.1-20110427.0
anaconda-13.21.115-1.el6

How reproducible:
always

Steps to Reproduce:
1. run installation in graphical mode
2. select Custom partitioning
3. create some RAID partitions (for example 5)
4. Try to create new RAID1 device using all the RAID partitions, change number of spares

Actual results:
Cannot modify number of spares

Expected results:
Number of spares is editable

--- Additional comment from akozumpl@redhat.com on 2011-05-27 17:42:20 EEST ---

patch for master is awaiting review:

https://www.redhat.com/archives/anaconda-devel-list/2011-May/msg00243.html

--- Additional comment from akozumpl@redhat.com on 2011-06-01 10:56:02 EEST ---

Fixed on master: 3c53d72b4a8924a52d8657ca3c3aa18528d55d2f

--- Additional comment from akozumpl@redhat.com on 2011-06-10 11:15:15 EEST ---

Fixed by 15f1c2dfc663ce664015610517b7dd973bb2a262.

--- Additional comment from atodorov@redhat.com on 2011-08-09 16:51:47 EEST ---

Created attachment 517418 [details]
screenshot raid dialog

I don't think this is fully fixed. As you can see on the attached screenshot the number of spares field is editable but it allows me to select more spares than I have raid partitions. 

In this case I have selected 2 raid members and 3 spares which is invalid. Anaconda lets me save this config and after writing changes to disk it dies with
ERROR: mdadm: invalid number of raid devices

--- Additional comment from atodorov@redhat.com on 2011-08-09 16:52:22 EEST ---

Moved back to ASSIGNED. Tested with anaconda-13.21.126.

--- Additional comment from akozumpl@redhat.com on 2011-08-10 18:28:47 EEST ---

(In reply to comment #5)
> Created attachment 517418 [details]
> screenshot raid dialog
> 
> I don't think this is fully fixed. As you can see on the attached screenshot
> the number of spares field is editable but it allows me to select more spares
> than I have raid partitions. 
> 
> In this case I have selected 2 raid members and 3 spares which is invalid.
> Anaconda lets me save this config and after writing changes to disk it dies
> with
> ERROR: mdadm: invalid number of raid devices

I was able to reproduce this exact scenario in 6.1 so this is not a regression. It is also a different problem because the underlying library simply doesn't tell us the correct upper limit on the number of spares depending on the number of raid devices used. Please open a different bug for that, CC me and we can target it for 6.3.

--- Additional comment from atodorov@redhat.com on 2011-08-10 18:38:39 EEST ---

Moving to VERIFIED and cloning for the other issue.
Comment 1 RHEL Product and Program Management 2011-08-11 10:51:57 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.
Comment 3 Ales Kozumplik 2011-08-15 06:20:53 EDT
Fixed by d8e574130f0d4ba262938f419418e4ae23e3b64f.
Comment 4 Ales Kozumplik 2011-08-15 07:26:44 EDT
(merged onto the master branch: d2d79c1e068ce15d83db3c98066dbada9aea31a1)
Comment 7 Alexander Todorov 2011-08-17 10:49:42 EDT
With anaconda-13.21.128 the number of spares changes dynamically based on selected RAID level and number of selected raid partitions. Moving to VERIFIED.
Comment 8 errata-xmlrpc 2011-12-06 05:40:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html

Note You need to log in before you can comment on or make changes to this bug.