Bug 729830 - [abrt] yum-3.2.29-8.fc15: misc.py:943:stat_f:OSError: [Errno 13] Permission denied: '/var/lib/yum/yumdb/S/3b9a8c2607a9afd7bc93cd76caebc4521b89499b-SDL_image-1.2.10-2.fc15-x86_64/from_repo'
Summary: [abrt] yum-3.2.29-8.fc15: misc.py:943:stat_f:OSError: [Errno 13] Permission d...
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:69c2404a0bce84136b5a131ae16...
: 732318 732319 732320 742881 744391 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 00:51 UTC by Steve Chapel
Modified: 2014-01-21 23:19 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-04 07:03:19 UTC


Attachments (Terms of Use)

Description Steve Chapel 2011-08-11 00:51:10 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        /usr/bin/python /usr/bin/yum info
comment:        I typed the command "yum info" at the command prompt as an unprivileged user.
component:      yum
executable:     /usr/bin/yum
kernel:         2.6.38.8-35.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        yum-3.2.29-8.fc15
reason:         misc.py:943:stat_f:OSError: [Errno 13] Permission denied: '/var/lib/yum/yumdb/S/3b9a8c2607a9afd7bc93cd76caebc4521b89499b-SDL_image-1.2.10-2.fc15-x86_64/from_repo'
time:           Wed Aug 10 20:48:39 2011
uid:            500
username:       schapel

backtrace:
:misc.py:943:stat_f:OSError: [Errno 13] Permission denied: '/var/lib/yum/yumdb/S/3b9a8c2607a9afd7bc93cd76caebc4521b89499b-SDL_image-1.2.10-2.fc15-x86_64/from_repo'
:
:Traceback (most recent call last):
:  File "/usr/bin/yum", line 29, in <module>
:    yummain.user_main(sys.argv[1:], exit_code=True)
:  File "/usr/share/yum-cli/yummain.py", line 267, in user_main
:    errcode = main(args)
:  File "/usr/share/yum-cli/yummain.py", line 120, in main
:    result, resultmsgs = base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 432, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/yumcommands.py", line 341, in doCommand
:    '=' : clir, 'not in' : clie})
:  File "/usr/share/yum-cli/output.py", line 671, in listPkgs
:    self.infoOutput(pkg, highlight=highlight)
:  File "/usr/share/yum-cli/output.py", line 589, in infoOutput
:    if pkg.repoid == 'installed' and 'from_repo' in pkg.yumdb_info:
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1828, in __contains__
:    x = self.get(attr)
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1858, in get
:    res = self._read(attr)
:  File "/usr/lib/python2.7/site-packages/yum/rpmsack.py", line 1775, in _read
:    info = misc.stat_f(fn)
:  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 943, in stat_f
:    return os.stat(filename)
:OSError: [Errno 13] Permission denied: '/var/lib/yum/yumdb/S/3b9a8c2607a9afd7bc93cd76caebc4521b89499b-SDL_image-1.2.10-2.fc15-x86_64/from_repo'
:
:Local variables in innermost frame:
:e: OSError(13, 'Permission denied')
:filename: '/var/lib/yum/yumdb/S/3b9a8c2607a9afd7bc93cd76caebc4521b89499b-SDL_image-1.2.10-2.fc15-x86_64/from_repo'

Comment 1 Zdeněk Pavlas 2011-10-03 13:27:06 UTC
*** Bug 742881 has been marked as a duplicate of this bug. ***

Comment 2 Zdeněk Pavlas 2011-10-03 13:28:44 UTC
*** Bug 732318 has been marked as a duplicate of this bug. ***

Comment 3 Zdeněk Pavlas 2011-10-03 13:30:01 UTC
*** Bug 732319 has been marked as a duplicate of this bug. ***

Comment 4 Zdeněk Pavlas 2011-10-03 13:30:34 UTC
*** Bug 732320 has been marked as a duplicate of this bug. ***

Comment 5 Zdeněk Pavlas 2011-10-04 07:03:19 UTC
umask override and error handling added in commit cbaf99fddabc2f96a87a329dbf078dec95164e04.

Comment 6 Zdeněk Pavlas 2011-10-10 07:24:09 UTC
*** Bug 744391 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.