Bug 729851 - losing Punjabi (pa) translation for project due to different language code in zanata
losing Punjabi (pa) translation for project due to different language code in...
Status: CLOSED NOTABUG
Product: Zanata
Classification: Community
Component: ProjectType-Code (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: zanata-dev-internal
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-10 23:20 EDT by A S Alam
Modified: 2013-07-02 21:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-11 01:23:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2011-08-10 23:20:08 EDT
Description of problem:
zanata has Punjabi language code (pa-guru-in)

but most project use 'pa' code for Punjabi

Now when Fedora project use zanata, Translation is showing 0% Done.
while those project has ~100% Translation (working for other locale hi,gu etc).

iok, system-config-langauge

Version-Release number of selected component (if applicable):
(20110509-2113)

How reproducible:


Steps to Reproduce:
1. https://fedora.zanata.org/zanata/project/iteration_status.seam?iterationSlug=f16&projectSlug=system-config-language
2. pa-guru-in status - 0% Done
3. https://www.transifex.net/projects/p/system-config-language/resource/default/
4. pa - 100% done
  
Actual results:
Punjabi (pa) Translation missing for present and coming project

Expected results:
Punjabi translation should be there

Additional info:
Please change code to 'pa' instead of pa-guru-in

'pa' is used by fedora, gnome, kde
Comment 1 Sean Flanigan 2011-08-11 00:23:02 EDT
I have added the locale code 'pa'.  I would have disabled the code 'pa-Guru-IN', but I notice it already has some translations.  Do you need to export them, or can I go ahead and disable it?
Comment 2 Sean Flanigan 2011-08-11 00:32:42 EDT
By the way, it's also possible to use locale mapping to convert 'pa' in your local machine (where you run "zanata push") to 'pa-Guru-IN' in the Zanata server.  
for example, in zanata.xml:

        <locale map-from="pa">pa-Guru-IN</locale>


But that's just FYI, it sounds like 'pa' is the better choice in this case.
Comment 3 A S Alam 2011-08-11 01:12:37 EDT
(In reply to comment #1)
> I have added the locale code 'pa'.  I would have disabled the code
> 'pa-Guru-IN', but I notice it already has some translations.  Do you need to
> export them, or can I go ahead and disable it?

those translation just for Testing. Please skip translation and disable it
Comment 4 Sean Flanigan 2011-08-11 01:23:15 EDT
Server configuration updated to enable 'pa' and disable 'pa-Guru-IN'.
Comment 5 A S Alam 2011-08-11 01:28:40 EDT
Is this really NOTBUG "The problem described is not a bug"?
Comment 6 Sean Flanigan 2011-08-11 01:44:36 EDT
It's hard to know how to categorise it in Bugzilla, because it's a configuration problem with the way this server was set up; it's not a bug in Zanata's code.  To fix it, I just logged in as an admin and changed a couple of things.  

NOTABUG
WONTFIX
DEFERRED
WORKSFORME
CURRENTRELEASE
RAWHIDE
ERRATA
DUPLICATE
UPSTREAM
NEXTRELEASE
CANTFIX

NOTABUG isn't ideal, but all the others seemed less accurate to me.  Which would you suggest?

Note You need to log in before you can comment on or make changes to this bug.