Bug 729945 - nwfilter: tolerate disappearing interfaces while instantiating filter
Summary: nwfilter: tolerate disappearing interfaces while instantiating filter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 11:00 UTC by Stefan Berger
Modified: 2011-12-06 11:26 UTC (History)
7 users (show)

Fixed In Version: libvirt-0.9.4-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:26:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Stefan Berger 2011-08-11 11:00:16 UTC
Description of problem:

Occasionally the instantiations of nwfilters can fail.


Version-Release number of selected component (if applicable):

libvirt 0.9.4

How reproducible:


From libvirt-tck run the test scripts/nwfilter/060-concurrency.t

May be difficult to reproduce. One of my machines doesn't show it at all, another one with more processors shows it.

Actual results:

Test does not finish and displays an error while running.

Expected results:

Test should finish.

Additional info:



Please apply commit 

http://libvirt.org/git/?p=libvirt.git;a=commit;h=762101c7affbd32af18eccc07249c2684cbb84a2

to RHEL 6.2.

Comment 2 Daniel Veillard 2011-08-11 11:05:07 UTC
Patch posted and applied upstream,

Daniel

Comment 3 Daniel Veillard 2011-08-13 15:03:27 UTC
git commit 762101c7affbd32af18eccc07249c2684cbb84a2

Comment 7 dyuan 2011-08-17 01:54:22 UTC
Move it to VERIFIED according to comment 6, thanks.

Comment 8 errata-xmlrpc 2011-12-06 11:26:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.