Bug 730005 - qpid-route command 'link list' possibly mistyped to 'list connections'
Summary: qpid-route command 'link list' possibly mistyped to 'list connections'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Programming_Reference
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 2.2
: ---
Assignee: Joshua Wulf
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 14:10 UTC by Zdenek Kraus
Modified: 2014-10-19 22:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-20 03:13:13 UTC


Attachments (Terms of Use)

Description Zdenek Kraus 2011-08-11 14:10:28 UTC
Description of problem:
qpidd-route command  'link list', which is offered by program, mismatch from command 'list connections' in documentation. I suggests to replace command in documentation instead of changing program.

Version-Release number of selected component (if applicable):
rhm-docs-0.10-2.el5
qpid-tools-0.10-6.el5


How reproducible:
100%
  
Actual results:
8.4.6. Resilient Connections
When a broker route is created, or when a durable broker route is restored after broker restart, a connection is created between the source broker and the destination broker. The connections used between brokers are called resilient connections; if the connection fails due to a communication error, it attempts to reconnect. The retry interval begins at 2 seconds and, as more attempts are made, grows to 64 seconds, and continues to retry every 64 seconds thereafter. If the connection fails due to an authentication problem, it will not continue to retry.
The command list connections can be used to show the resilient connections for a broker:

$ qpid-route list connections localhost:10001

Host            Port    Transport Durable  State             Last Error
=============================================================================
localhost       10002   tcp          N     Operational       
localhost       10003   tcp          N     Operational       
localhost       10009   tcp          N     Waiting           Connection refused

In the above output, Last Error contains the string representation of the last connection error received for the connection. State represents the state of the connection, and may be one of the following values:

Table 8.2. State values in $ qpid-route list connections
Waiting 	Waiting before attempting to reconnect.
Connecting 	Attempting to establish the connection.
Operational 	The connection has been established and can be used.
Failed 	The connection failed and will not retry (usually because authentication failed).
Closed 	The connection has been closed and will soon be deleted.
Passive 	If a cluster is federated to another cluster, only one of the nodes has an actual connection to remote node. Other nodes in the cluster have a passive connection. 

Expected results:
8.4.6. Resilient Connections
When a broker route is created, or when a durable broker route is restored after broker restart, a connection is created between the source broker and the destination broker. The connections used between brokers are called resilient connections; if the connection fails due to a communication error, it attempts to reconnect. The retry interval begins at 2 seconds and, as more attempts are made, grows to 64 seconds, and continues to retry every 64 seconds thereafter. If the connection fails due to an authentication problem, it will not continue to retry.
The command link list can be used to show the resilient connections for a broker:

$ qpid-route link list localhost:10001

Host            Port    Transport Durable  State             Last Error
=============================================================================
localhost       10002   tcp          N     Operational       
localhost       10003   tcp          N     Operational       
localhost       10009   tcp          N     Waiting           Connection refused

In the above output, Last Error contains the string representation of the last connection error received for the connection. State represents the state of the connection, and may be one of the following values:

Table 8.2. State values in $ qpid-route link list
Waiting 	Waiting before attempting to reconnect.
Connecting 	Attempting to establish the connection.
Operational 	The connection has been established and can be used.
Failed 	The connection failed and will not retry (usually because authentication failed).
Closed 	The connection has been closed and will soon be deleted.
Passive 	If a cluster is federated to another cluster, only one of the nodes has an actual connection to remote node. Other nodes in the cluster have a passive connection.

Comment 1 Petr Matousek 2011-08-16 09:28:24 UTC
Note: This issue was already reported as a part of Bug 709693 (point 2), thus I suggest to solve this bug and 709693 together.

Comment 3 David Ryan 2012-09-13 07:29:32 UTC
Verified on stage.

Comment 4 Cheryn Tan 2012-09-20 02:53:41 UTC
Released for MRG 2.2


Note You need to log in before you can comment on or make changes to this bug.