Bug 730036 - CPUScaling test aborted during the test in RH5.7 x86 XEN kernel
Summary: CPUScaling test aborted during the test in RH5.7 x86 XEN kernel
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 5
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 15:32 UTC by chau nguyen
Modified: 2018-11-28 21:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-23 19:17:44 UTC


Attachments (Terms of Use)
Log (7.25 MB, application/octet-stream)
2011-08-12 21:16 UTC, chau nguyen
no flags Details
output.log (5.38 KB, text/plain)
2011-08-12 21:22 UTC, chau nguyen
no flags Details

Description chau nguyen 2011-08-11 15:32:53 UTC
Description of problem: CPUScaling test aborted during the test in RH5.7 x86 XEN kernel



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install RH5.7 x86 XEN kernel build GA
2. Install RH certification test kits
3.Run CPUScaling test
  
Actual results:
Aborted

Expected results:
Pass

Additional info:
CPUScaling test aborted during the test in RH5.7 x86 in XEN kernel because of no physical_package_id directory.  However, there is physical_package_id directory in baremetal kernel, and the test passed without any problem.

Comment 1 chau nguyen 2011-08-12 21:16:58 UTC
Created attachment 518109 [details]
Log

Comment 2 chau nguyen 2011-08-12 21:22:36 UTC
Created attachment 518111 [details]
output.log

Comment 3 Rob Landry 2011-08-17 19:43:43 UTC
Cpuscaling testing with the -xen kernel is not required.  Also as noted -xen does not currently provide physical_package_id even in dom0 which is requierd for the cpuscaling test so I'm going to go ahead and close this as not a bug given expected behavior and not a certification blocker.

A RHEL bug could be opened to request the physical package id be provided, however (and this is just a guess I do not speak for the RHEL team) but I would suspect that would be denied without some other use case.


Note You need to log in before you can comment on or make changes to this bug.