Bug 730064 - nut-client can't be installed in initial installation because of missing requires
Summary: nut-client can't be installed in initial installation because of missing requ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nut
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 16:38 UTC by Gerd v. Egidy
Modified: 2011-09-30 19:04 UTC (History)
1 user (show)

Fixed In Version: nut-2.6.1-4.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 22:30:59 UTC


Attachments (Terms of Use)
patch to fix the problem (670 bytes, patch)
2011-08-11 16:38 UTC, Gerd v. Egidy
no flags Details | Diff

Description Gerd v. Egidy 2011-08-11 16:38:55 UTC
Created attachment 517845 [details]
patch to fix the problem

Description of problem:
when installing nut-client during initial system installation (e.g. with kickstart), the installation can fail because the dialout group does not yet exist.

This happens due to a missing Requires(pre) for udev for the nut-client subpackage.


Version-Release number of selected component (if applicable):
2.6.1-1.fc15

How reproducible:
most times, depends on selected packages

Steps to Reproduce:
1. create a kickstart file which installs nut-client
2. use it to install the system
  
Actual results:
installation aborts with a confusing error message about missing rights or download errors.

the install log shows that the pre-script of nut-client failed because of the missing dialin group

Expected results:
installation works.

Comment 1 Fedora Update System 2011-08-12 13:03:31 UTC
nut-2.6.1-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/nut-2.6.1-2.fc14

Comment 2 Fedora Update System 2011-08-13 02:28:23 UTC
Package nut-2.6.1-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nut-2.6.1-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/nut-2.6.1-2.fc14
then log in and leave karma (feedback).

Comment 3 Gerd v. Egidy 2011-08-16 07:44:32 UTC
Hi,

thanks for taking care of this issue this fast. I can confirm that it doesn't happen with your updated version anymore.

But please take a look at the %pre of the -cgi subpackage. It does the same usermod-call using the dialout group as the -client subpackage. I haven't used the -cgi, but I highly suspect that it is affected by this problem too. So I propose that you add a Requires(pre): udev to the cgi subpackage too.

Comment 4 Fedora Update System 2011-08-17 08:24:46 UTC
nut-2.6.1-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nut-2.6.1-3.fc15

Comment 5 Fedora Update System 2011-08-17 08:24:53 UTC
nut-2.6.1-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nut-2.6.1-4.fc16

Comment 6 Gerd v. Egidy 2011-08-17 08:58:37 UTC
Hi, thanks for updating again, the .spec looks fine to me now.

Comment 7 Fedora Update System 2011-08-22 16:00:57 UTC
nut-2.6.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/nut-2.6.1-3.fc14

Comment 8 Fedora Update System 2011-08-22 16:01:12 UTC
nut-2.6.1-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nut-2.6.1-4.fc15

Comment 9 Fedora Update System 2011-09-14 22:30:36 UTC
nut-2.6.1-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-09-14 22:31:36 UTC
nut-2.6.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-09-30 19:04:44 UTC
nut-2.6.1-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.