Bug 730087 - matahari sysconfig crashes
Summary: matahari sysconfig crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Stokes
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 18:01 UTC by Dave Johnson
Modified: 2011-12-06 11:39 UTC (History)
4 users (show)

Fixed In Version: matahari-0.4.2-8.el6
Doc Type: Bug Fix
Doc Text:
No description required
Clone Of:
Environment:
Last Closed: 2011-12-06 11:39:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-11 18:01:33 UTC
Description of problem:
========================
Trying to do any run_uri or run_string command always results in the daemon crashing.  Here is what I tried have tried from qmf and python console:

sysconfig.run_uri("http://matahariproject.org/atom.xml", 0, "puppet", "dave")
sysconfig.run_uri("http://127.0.0.1/site.pp", 0, "puppet", "dave")
sysconfig.run_string('file { "/etc/sudoers":\n    owner => root, group => root, mode => 440\n}\n', 0, 'puppet', 'dave')

Always results in something like the following in /var/log/messages
Aug 11 13:36:41 hp-dl360g5-01 abrt[6299]: saved core dump of pid 6225 (/usr/sbin/matahari-qmf-sysconfigd) to /var/spool/abrt/ccpp-2011-08-11-13:36:41-6225.new/coredump (23089152 bytes)
Aug 11 13:36:41 hp-dl360g5-01 abrtd: Directory 'ccpp-2011-08-11-13:36:41-6225' creation detected
Aug 11 13:36:41 hp-dl360g5-01 abrtd: Package 'matahari-sysconfig' isn't signed with proper key  
Aug 11 13:36:41 hp-dl360g5-01 abrtd: Corrupted or bad dump /var/spool/abrt/ccpp-2011-08-11-13:36:41-6225 (res:2), deleting

Version-Release number of selected component (if applicable):
==============================================================
matahari-sysconfig-0.4.2-5.el6.x86_64
  with:
    puppet-server-2.6.6-1.el6_0.noarch
    puppet-2.6.6-1.el6_0.noarch

How reproducible:
=================
100%

Steps to Reproduce:
====================
1.  install/start matahari broker and sysconfig agent
2.  either through qmf-tool or python console, run the above commands

Comment 2 Adam Stokes 2011-08-11 20:01:41 UTC
Awaiting review on ML

Comment 4 Dave Johnson 2011-08-17 14:46:46 UTC
I am still seeing this as an issue in v0.4.2-6 with the same version of puppet.

Comment 5 Andrew Beekhof 2011-08-18 03:35:13 UTC
Adam: which patch were/are you waiting review for?  Has it been committed?  I don't see one referencing this bug number.

Please do not put bugs into POST until the patch has been pushed upstream.

Comment 9 Dave Johnson 2011-08-24 20:06:33 UTC
good 2 go in v0.4.2-9

Comment 10 Russell Bryant 2011-11-16 21:41:48 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required

Comment 11 errata-xmlrpc 2011-12-06 11:39:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.