Bug 730096 - Cannot create multiple environment paths
Summary: Cannot create multiple environment paths
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Katello
Classification: Retired
Component: WebUI
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Jason E. Rist
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 18:32 UTC by Jeff Weiss
Modified: 2014-11-09 22:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 19:35:01 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2011-08-11 18:32:11 UTC
Description of problem:


Version-Release number of selected component (if applicable):
katello-0.1.59-1.git.26.7d5ed07.fc14.noarch

How reproducible:


Steps to Reproduce:
1. Create an org
2. In that org, create env Development with prior Locker.
3. Create QA with prior Development
4. Start creating a new environment "Stage", with prior Development
  
Actual results:
Development is not selectable as a prior.

Expected results:
Development is an available prior.

Additional info:
The way the env picker ui works, for instance, on the promotions page, or on the System/Environments page, it shows multiple paths.  I thought the whole reason to show the paths was because when you're promoting, you can't just select "Development", you need to select the path that you want to promote to, there could be more than 1.  But it looks like now there can only be 1.


Note You need to log in before you can comment on or make changes to this bug.