Bug 730107 - abrt events should have a way to be aborted
Summary: abrt events should have a way to be aborted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Denys Vlasenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-11 19:18 UTC by Chris Meek
Modified: 2013-02-27 00:09 UTC (History)
8 users (show)

Fixed In Version: abrt-2.0.6-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-21 22:51:29 UTC


Attachments (Terms of Use)

Description Chris Meek 2011-08-11 19:18:51 UTC
Description of problem:
When abrt-action-install-debuginfo-to-abrt-cache starts to download debuginfo, the process cannot be cancelled. If it is a large debuginfo file, this would force you to finish the download, even if you decided that it is not worth downloading. Typing ctrl-c does not stop the download, nor any other signal.

Version-Release number of selected component (if applicable):
abrt-2.0.3-1.f15.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Start a download: echo 67b1a5daf785521a097dd1f29fe9513f60f842f0 | /usr/bin/abrt-action-install-debuginfo-to-abrt-cache  -y --ids=-

2. Before the download finishes, try to cancel it, with ctrl-c or any other command.
  
Actual results:
It appears to cancel the main program, but the download process continues. It appears on the next line after going back to the command prompt.

Expected results:
There should be some way to cancel the download.

Additional info:

Comment 1 Denys Vlasenko 2011-10-11 09:49:30 UTC
The same bug in different bug tracker:
https://fedorahosted.org/abrt/ticket/66

Comment 2 Denys Vlasenko 2011-10-17 13:14:20 UTC
Fixed in git:

commit 4e978b29c128fc204f52fc322789ac6137bfd21c
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Mon Oct 17 15:11:13 2011 +0200

    wizard: add [cancel] btn to reporting log window too


commit 3a6baf1a439f7b65a1876977dd9e53c39d87f233
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Mon Oct 17 14:29:13 2011 +0200

    wizard: add a button to cancel running event.

Comment 3 Fedora Update System 2011-11-05 18:58:03 UTC
abrt-2.0.6-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/abrt-2.0.6-1.fc16

Comment 4 Fedora Update System 2011-11-06 23:55:33 UTC
Package abrt-2.0.6-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.6-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15513
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-11-21 22:51:29 UTC
abrt-2.0.6-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Chris Meek 2012-01-31 16:14:04 UTC
I tested the most recent version: abrt-2.0.7-2.fc16 and there still appears to be
some issues with aborting the download process. When calling abrt-action-install-debuginfo-to-abrt-cache directly: 

$ echo f09df0d796fef1ba7d06baa9b614286295c6807d | /usr/libexec/abrt-action-install-debuginfo-to-abrt-cache -y --ids=-

and then pressing ctrl-c in the middle of the download process, it sometimes successfully cancels the download, but sometimes it does not. I haven't noticed any pattern on why it sometimes works or not...it appears random.

I also tried it by passing SIGINT (or even SIGKILL) to it from within our program, but that didn't appear to work at all. Perhaps this is due to abrt-action-install-debuginfo-to-abrt-cache being a wrapper for abrt-action-install-debuginfo.


Note You need to log in before you can comment on or make changes to this bug.