Bug 73012 - up2date fails at "packages required to solve dependencies"
up2date fails at "packages required to solve dependencies"
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2002-08-29 18:49 EDT by Peter L. Hurd
Modified: 2015-01-07 19:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-05-20 10:26:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter L. Hurd 2002-08-29 18:49:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
[root@localhost pete]# up2date
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1311, in onPackagePageNext
  File "/usr/share/rhn/up2date_client/up2date.py", line 405, in dryRun
    rc = depsolve.run()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 473, in run
AttributeError: setProbFilter
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1375, in onDependencyPagePrepare
    for pkg in self.depPackages:
AttributeError: Gui instance has no attribute 'depPackages'

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install up2date-2.9.55-2, up2date-gnome-2.9.55-2, rpm-4.1-1.02
2. run up2date

Actual Results:  Hangs at "packages required to solve dependencies"

Additional info:
Comment 1 Adrian Likins 2002-08-29 18:52:07 EDT
I think you need a newer rpm...

Can you grab the latest out of rawhide and try it?

I think the spec file isnt requiring the absolute latest
version, which up2date needs...
Comment 2 Peter L. Hurd 2002-08-29 19:07:36 EDT
Same behaviour with up2date 2.9.57-1

Though I see now that it's possible to just close the progress bar window and 
proceed.  I think this was mentioned on the (null) mailing list but I didn't 
Comment 3 Adrian Likins 2002-08-29 19:11:36 EDT
ooops, sorry. I meant grab the latest version of rpm...
Comment 4 Michael Young 2002-08-30 07:47:43 EDT
Note rpm-python, rhpl and libelf also need to be recent to get up2date-2.9.55-2
to work.
Comment 5 Need Real Name 2002-08-30 09:46:27 EDT


up2date from up2date-2.9.55-2 gives 

Error communicating with server.  The message was:
Proxy Error


Traceback (most recent call last):
  File "/usr/sbin/up2date", line 800, in ?
  File "/usr/sbin/up2date", line 576, in main
    from up2date_client import gui
  File "/usr/share/rhn/up2date_client/gui.py", line 31, in ?
    from translate import _, N_, cat

Comment 6 Adrian Likins 2002-08-31 23:27:37 EDT
this seems to be working fine in 2.9.64
Comment 7 Daniel Resare 2002-09-06 17:11:23 EDT
Proxy error is probably an unrelated error. The thing that did it for me was
upgrading to rpm-python-4.1-1.02. I believe the status of this can be set to FIXED
Comment 8 Peter L. Hurd 2002-09-06 17:44:09 EDT
Yeah, I think it's FIXED.
Comment 9 Daniel Resare 2003-01-20 18:34:43 EST
This one has been fixed forever. Perhaps moving it to status FIXED would be in
Comment 10 Matt Jamison 2003-05-20 10:26:57 EDT
resolving bug.

Note You need to log in before you can comment on or make changes to this bug.