Bug 730207 - TUI: RHEVH can't display NIC model correct in Network page, there always display unknown.
Summary: TUI: RHEVH can't display NIC model correct in Network page, there always disp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 06:53 UTC by cshao
Modified: 2011-12-06 19:26 UTC (History)
8 users (show)

Fixed In Version: ovirt-node-2.0.2-0.6.gitcc6ba8c.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:26:24 UTC


Attachments (Terms of Use)
net card model (42.18 KB, image/jpeg)
2011-08-12 06:53 UTC, cshao
no flags Details
model display issue (300.00 KB, application/x-gzip)
2011-08-30 11:01 UTC, Guohua Ouyang
no flags Details
working screenshot (10.53 KB, image/png)
2011-08-31 01:31 UTC, Joey Boggs
no flags Details
wrong network model is displayed (126.00 KB, application/x-gzip)
2011-09-05 03:03 UTC, Guohua Ouyang
no flags Details
network page (91.71 KB, image/png)
2011-09-06 04:22 UTC, Guohua Ouyang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description cshao 2011-08-12 06:53:33 UTC
Created attachment 517968 [details]
net card model

Description of problem:
TUI: RHEVH can't recognise net card model in Network page.

Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.12.el6

How reproducible:
100%

Steps to Reproduce:
1. Install RHEVH and configure Network.
2. Enter Network page, check NIC Model line.
3.
  
Actual results:
Net card model shows unknown in network page.

# ethtool -i eth1
driver: e1000e
version: 1.3.10-k2
firmware-version: 0.4-3
bus-info: 0000:00:19.0

Expected results:
RHEVH can recognise net card model in Network page.

Additional info:

Comment 3 Guohua Ouyang 2011-08-30 11:01:10 UTC
Created attachment 520589 [details]
model display issue

Tested on two machines with 6.2-0.14:
1. on local machine, it only displayed one nic's model info. (local_network_model_display.png)

2. on another machine, it displayed all nic's model info with the same. 
(s1_rhevh_02_lspci.png,  s1_rhevh_02_network_model_display.png)

Comment 5 Joey Boggs 2011-08-31 01:31:10 UTC
Created attachment 520716 [details]
working screenshot

Comment 7 Guohua Ouyang 2011-09-05 03:03:09 UTC
Created attachment 521422 [details]
wrong network model is displayed

tested 6.2-0.15 on two machines:
1. on my local dell optiplex 760, it displayed the two nics' model correctly.
2. on the other machine, there are 4 nics, only two nics' model is displayed, other two displayed blank. And the two nics displayed the VGA device's model instead of network device's model.

Comment 9 Guohua Ouyang 2011-09-06 04:22:32 UTC
Created attachment 521571 [details]
network page

#lspci -n
00:00.0 0600: 1002:7910
00:01.0 0604: 1002:7912
00:06.0 0604: 1002:7916
00:07.0 0604: 1002:7917
00:12.0 0106: 1002:4380
00:13.0 0c03: 1002:4387
00:13.1 0c03: 1002:4388
00:13.2 0c03: 1002:4389
00:13.3 0c03: 1002:438a
00:13.4 0c03: 1002:438b
00:13.5 0c03: 1002:4386
00:14.0 0c05: 1002:4385 (rev 13)
00:14.1 0101: 1002:438c
00:14.2 0403: 1002:4383
00:14.3 0601: 1002:438d
00:14.4 0604: 1002:4384
00:18.0 0600: 1022:1100
00:18.1 0600: 1022:1101
00:18.2 0600: 1022:1102
00:18.3 0600: 1022:1103
01:05.0 0300: 1002:791e
07:04.0 0200: 8086:107c (rev 05)
20:00.0 0200: 14e4:1639 (rev 20)
20:00.1 0200: 14e4:1639 (rev 20)
3f:00.0 0200: 14e4:167b (rev 02)

Comment 11 Guohua Ouyang 2011-09-07 01:45:41 UTC
lspci output is attached in comment #7 actually, copy it below:
# lspci
00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 13)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS690 [Radeon X1200 Series]
07:04.0 Ethernet controller: Intel Corporation 82541PI Gigabit Ethernet Controller (rev 05)
20:00.0 Ethernet controller: Broadcom Corporation NetXtreme II BCM5709 Gigabit Ethernet (rev 20)
20:00.1 Ethernet controller: Broadcom Corporation NetXtreme II BCM5709 Gigabit Ethernet (rev 20)
3f:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5755 Gigabit Ethernet PCI Express (rev 02)

Comment 13 Guohua Ouyang 2011-09-08 01:46:49 UTC
run the script and got below:

<gudev.Device object at 0x7fb7874e5820 (GUdevDevice at 0x2335e30)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/pci0000:00/0000:00:06.0/0000:20:00.0/net/eth0
   property INTERFACE: eth0
   property IFINDEX: 2
   property SUBSYSTEM: net

<gudev.Device object at 0x7fb7874e5870 (GUdevDevice at 0x2335e80)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/pci0000:00/0000:00:06.0/0000:20:00.1/net/eth1
   property INTERFACE: eth1
   property IFINDEX: 3
   property SUBSYSTEM: net

<gudev.Device object at 0x7fb7874e58c0 (GUdevDevice at 0x2335ed0)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/pci0000:00/0000:00:07.0/0000:3f:00.0/net/eth3
   property INTERFACE: eth3
   property IFINDEX: 5
   property SUBSYSTEM: net

<gudev.Device object at 0x7fb7874e5910 (GUdevDevice at 0x2335f20)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/pci0000:00/0000:00:14.4/0000:07:04.0/net/eth2
   property INTERFACE: eth2
   property IFINDEX: 4
   property SUBSYSTEM: net

<gudev.Device object at 0x7fb7874e5960 (GUdevDevice at 0x2335f70)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/virtual/net/breth0
   property DEVTYPE: bridge
   property INTERFACE: breth0
   property IFINDEX: 21
   property SUBSYSTEM: net

<gudev.Device object at 0x7fb7874e59b0 (GUdevDevice at 0x2336000)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/virtual/net/breth1
   property DEVTYPE: bridge
   property INTERFACE: breth1
   property IFINDEX: 22
   property SUBSYSTEM: net

<gudev.Device object at 0x7fb7874e5a00 (GUdevDevice at 0x2336050)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/virtual/net/breth2
   property DEVTYPE: bridge
   property INTERFACE: breth2
   property IFINDEX: 20
   property SUBSYSTEM: net

<gudev.Device object at 0x7fb7874e5a50 (GUdevDevice at 0x23360a0)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/virtual/net/breth3
   property DEVTYPE: bridge
   property INTERFACE: breth3
   property IFINDEX: 18
   property SUBSYSTEM: net

<gudev.Device object at 0x7fb7874e5aa0 (GUdevDevice at 0x23360f0)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/virtual/net/eth2.20
   property INTERFACE: eth2.20
   property IFINDEX: 19
   property SUBSYSTEM: net

<gudev.Device object at 0x7fb7874e5af0 (GUdevDevice at 0x2336140)>
   property UDEV_LOG: 3
   property DEVPATH: /devices/virtual/net/lo
   property INTERFACE: lo
   property IFINDEX: 1
   property SUBSYSTEM: net

Comment 22 Guohua Ouyang 2011-09-30 02:24:14 UTC
Verified on rhevh-6.2-20110929 build, all network device model display correct.

Comment 23 errata-xmlrpc 2011-12-06 19:26:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.