Bug 730208 - The quit of "virt-top --csv" will result in bad terminal.
Summary: The quit of "virt-top --csv" will result in bad terminal.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-top
Version: 6.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 06:56 UTC by Huming Jiang
Modified: 2011-12-06 17:12 UTC (History)
3 users (show)

Fixed In Version: virt-top-1.0.4-3.11.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 17:12:29 UTC


Attachments (Terms of Use)
The bad terminal (136.44 KB, image/png)
2011-08-12 06:56 UTC, Huming Jiang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1692 normal SHIPPED_LIVE virt-top bug fix and enhancement update 2011-12-06 00:49:53 UTC

Description Huming Jiang 2011-08-12 06:56:13 UTC
Created attachment 517971 [details]
The bad terminal

Description of problem:
After quit from "virt-top --csv", the terminal will be in abnormal mode.

Version-Release number of selected component (if applicable):
virt-top-1.0.4-3.10.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1.#virt-top --csv guestinfo.csv
2.Input 'q' to quit from virt-top

  
Actual results:
The terminal will be in abnormal mode. All the input command will not display. See the attachment.

Expected results:
The terminal should be good.

Additional info:

Comment 2 Richard W.M. Jones 2011-08-12 10:59:42 UTC
This was a bug introduced by the enhancement in bug 643893,
so in fact this was a regression in RHEL 6.1.

Fixed upstream in:

http://git.annexia.org/?p=virt-top.git;a=commitdiff;h=067b868b9cce7620774d7fb57dac6fd8df45d8df

Comment 3 Richard W.M. Jones 2011-08-12 11:02:38 UTC
(In reply to comment #2)
> This was a bug introduced by the enhancement in bug 643893,
> so in fact this was a regression in RHEL 6.1.
> 
> Fixed upstream in:

Wrong link.  The correct link is:

http://git.annexia.org/?p=virt-top.git;a=commit;h=20afbd9ba7055428a8ddfc13bba2e357836b461b

Comment 6 Huming Jiang 2011-08-16 06:15:39 UTC
Verified with the following components:
virt-top-1.0.4-3.11.el6.x86_64.rpm

Steps:
1.#virt-top --csv guestinfo.csv
2.Input 'q' to quit from virt-top

then the terminal is good.

So move the status to Verified.

Comment 7 errata-xmlrpc 2011-12-06 17:12:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1692.html


Note You need to log in before you can comment on or make changes to this bug.