Bug 730219 - [abrt] ibus-1.3.99.20110419-13.fc16: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: パス /org/freedesktop/IBus/InputContext_8 のオブジェクト上にインターフェイス 'org.freedesktop.IBus.InputContext' がありません
[abrt] ibus-1.3.99.20110419-13.fc16: connection.py:630:call_blocking:DBusExce...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:459805b03ba5bb93fc70d012b74...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-12 04:04 EDT by Jens Petersen
Modified: 2011-08-16 23:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 23:49:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2011-08-12 04:04:17 EDT
abrt version: 2.0.5
cmdline:        /usr/bin/python /usr/share/ibus/ui/gtk/main.py
executable:     /usr/share/ibus/ui/gtk/main.py
kernel:         3.0.0-1.fc16.i686
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: パス /org/freedesktop/IBus/InputContext_8 のオブジェクト上にインターフェイス 'org.freedesktop.IBus.InputContext' がありません
time:           Fri Aug 12 16:57:23 2011
uid:            1000
username:       petersen

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.UnknownMethod: パス /org/freedesktop/IBus/InputContext_8 のオブジェクト上にインターフェイス 'org.freedesktop.IBus.InputContext' がありません
:
:Traceback (most recent call last):
:  File "/usr/share/ibus/ui/gtk/panel.py", line 672, in __status_icon_activate_cb
:    menu = self.__create_im_menu()
:  File "/usr/share/ibus/ui/gtk/panel.py", line 629, in __create_im_menu
:    if self.__focus_ic == None or not self.__focus_ic.is_enabled():
:  File "/usr/lib/python2.7/site-packages/ibus/inputcontext.py", line 260, in is_enabled
:    return self.__context.IsEnabled()
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.UnknownMethod: パス /org/freedesktop/IBus/InputContext_8 のオブジェクト上にインターフェイス 'org.freedesktop.IBus.InputContext' がありません
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus.connection.Connection object at 0xa36f74c>
:args: ()
:utf8_strings: False
:bus_name: 'org.freedesktop.IBus'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: dbus.ObjectPath('/org/freedesktop/IBus/InputContext_8')
:timeout: -1.0
:signature: ''
:dbus_interface: 'org.freedesktop.IBus.InputContext'
:message: <dbus.lowlevel.MethodCallMessage object at 0xa2faee0>
:method: 'IsEnabled'

comment:
:Tried to activate ibus in xmonad-gnome session
:under GNOME fallback mode.
Comment 1 fujiwara 2011-08-16 22:02:50 EDT
Are you still able to see your problem?
I cannot reproduce your problem with xmonad-gnome.
It seems xmonad-gnome works fine with ibus. I selected xmonad-gnome on GDM login dialog.
Comment 2 Jens Petersen 2011-08-16 23:49:27 EDT
(In reply to comment #1)
> Are you still able to see your problem?

No, I can't.  I guess it is ok now. :)

Note You need to log in before you can comment on or make changes to this bug.