Bug 730259 - ghc-7.2.1 is available
Summary: ghc-7.2.1 is available
Keywords:
Status: CLOSED DUPLICATE of bug 753410
Alias: None
Product: Fedora
Classification: Fedora
Component: ghc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-12 10:15 UTC by Upstream Release Monitoring
Modified: 2012-02-06 08:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-13 14:13:45 UTC


Attachments (Terms of Use)

Description Upstream Release Monitoring 2011-08-12 10:15:26 UTC
Latest upstream release: 7.2.1
Current version in Fedora Rawhide: 7.0.4
URL: http://haskell.org/ghc/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Jens Petersen 2011-08-15 01:21:43 UTC
I am thinking to build this in rawhide for F17 nearer the end of the F16 cycle.
By that time 7.4 may already have been released, and hopefully a haskell-platform release.

Comment 2 Jens Petersen 2011-08-15 01:44:59 UTC
In the meantime/short-term there is a test build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3267317

The binary packages can be downloaded from http://kojipkgs.fedoraproject.org/scratch/petersen/task_3267317/

I will probably upload a build to fedorapeople later.

Comment 3 Jens Petersen 2011-09-01 10:28:37 UTC
I uploaded the build here:

http://petersen.fedorapeople.org/ghc-7.2/

until 7.2 is built for rawhide.

Comment 4 Jens Petersen 2011-09-14 00:34:39 UTC
Recap: no official haskell-platform release is planned for 7.2
nor any updates to ghc-7.2: ie I believe there won't be a 7.2.2.

ghc-7.4 which will be the next major stable release of ghc
is now expected at the end of 2011.

Work is currently undergoing to release an updated haskell-platform
for ghc-7.0.4.

It might still be worth putting 7.2.1 into rawhide though
to get a feel for the coming 7.4 release... 7.2.1 is also
the current default compiler in Hackage.

Comment 5 Jens Petersen 2011-09-26 02:00:20 UTC
Since no haskell-platform planned for ghc-7.2 - we could close this
and wait for 7.4.  Though I may still build 7.2 for rawhide.

Comment 6 Jens Petersen 2011-11-13 14:13:45 UTC

*** This bug has been marked as a duplicate of bug 753410 ***


Note You need to log in before you can comment on or make changes to this bug.