Bug 730489 - tracebacks are blocking basic register attempts
tracebacks are blocking basic register attempts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
: Regression
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-08-13 12:25 EDT by John Sefler
Modified: 2011-12-06 12:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:23:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-08-13 12:25:13 EDT
Description of problem:
a regression was recently introduced that affects registering a client.
The following traceback is occurring during a valid call to register....



[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin
Problem creating consumer Consumer [id = 8a90f8c631c3a8100131c3f0895806fc, type = ConsumerType [id=8a90f8c631c3a8100131c3a88e7b0001, label=system], getName() = jsefler-onprem-62server.usersys.redhat.com]
[root@jsefler-onprem-62server ~]# 


[root@jsefler-onprem-62server ~]# tail -f /var/log/rhsm/rhsm.log

2011-08-13 12:19:05,742 [INFO]  @connection.py:335 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
2011-08-13 12:19:05,743 [DEBUG]  @connection.py:175 - Loading CA PEM certificates from: /etc/rhsm/ca/
2011-08-13 12:19:05,743 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/fakamai-cp1.pem'
2011-08-13 12:19:05,744 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/jsefler-onprem-62candlepin.pem'
2011-08-13 12:19:05,744 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2011-08-13 12:19:05,745 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2011-08-13 12:19:05,747 [WARNING]  @connection.py:368 - Error fetching supported resources, this UEPConnection is likely not usable:
2011-08-13 12:19:05,748 [ERROR]  @connection.py:370 - No such file or directory
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 361, in _load_supported_resources
    resources_list = self.conn.request_get("/")
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 237, in request_get
    return self._request("GET", method)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 178, in _request
    context.load_cert(self.cert_file, keyfile=self.key_file)
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Context.py", line 76, in load_cert
    m2.ssl_ctx_use_cert(self.ctx, certfile)
SSLError: No such file or directory
2011-08-13 12:19:05,751 [INFO]  @connection.py:347 - Connection Established: host: jsefler-onprem-62candlepin.usersys.redhat.com, port: 8443, handler: /candlepin
2011-08-13 12:19:05,821 [INFO]  @connection.py:324 - Using basic authentication as: testuser1
2011-08-13 12:19:05,822 [DEBUG]  @connection.py:175 - Loading CA PEM certificates from: /etc/rhsm/ca/
2011-08-13 12:19:05,822 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/fakamai-cp1.pem'
2011-08-13 12:19:05,822 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/jsefler-onprem-62candlepin.pem'
2011-08-13 12:19:05,823 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2011-08-13 12:19:05,823 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2011-08-13 12:19:05,824 [DEBUG]  @connection.py:196 - Making request: GET /candlepin/
2011-08-13 12:19:05,858 [DEBUG]  @connection.py:203 - Response status: 200
2011-08-13 12:19:05,861 [DEBUG]  @connection.py:364 - Server supports the following resources:
2011-08-13 12:19:05,862 [DEBUG]  @connection.py:365 - {'serials': '/serials', 'status': '/status', 'owners': '/owners', 'jobs': '/jobs', 'users': '/users', 'consumers': '/consumers', 'subscriptions': '/subscriptions', 'admin': '/admin', 'consumertypes': '/consumertypes', 'statistics/generate': '/statistics/generate', 'content': '/content', 'pools': '/pools', 'products': '/products', 'activation_keys': '/activation_keys', 'atom': '/atom', 'entitlements': '/entitlements', 'events': '/events', 'crl': '/crl', 'rules': '/rules'}
2011-08-13 12:19:05,863 [INFO]  @connection.py:347 - Connection Established: host: jsefler-onprem-62candlepin.usersys.redhat.com, port: 8443, handler: /candlepin
2011-08-13 12:19:06,052 [DEBUG]  @cert_sorter.py:70 - Sorting product and entitlement cert status for: 2011-08-13 12:19:06.052199
2011-08-13 12:19:06,107 [DEBUG]  @cert_sorter.py:91 - Installed product IDs: ['100000000000060', '1144', '100000000000011', '100000000000010', '100000000000013', '100000000000012', '100000000000015', '27060', '68', '917571', '1', '37069', '37068', '37080', '37065', '37067', '37060', '37062', '100000000000006', '100000000000007', '100000000000004', '100000000000005', '100000000000002', '100000000000003', '100000000000000', '100000000000001', '100000000000020', '100000000000022', '100000000000009', '100000000000008', '37090', '37070']
2011-08-13 12:19:06,108 [DEBUG]  @cert_sorter.py:81 - valid entitled products: []
2011-08-13 12:19:06,108 [DEBUG]  @cert_sorter.py:82 - expired entitled products: []
2011-08-13 12:19:06,111 [DEBUG]  @connection.py:175 - Loading CA PEM certificates from: /etc/rhsm/ca/
2011-08-13 12:19:06,112 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/fakamai-cp1.pem'
2011-08-13 12:19:06,112 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/jsefler-onprem-62candlepin.pem'
2011-08-13 12:19:06,113 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2011-08-13 12:19:06,114 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2011-08-13 12:19:06,115 [DEBUG]  @connection.py:196 - Making request: POST /candlepin/consumers?owner=admin
2011-08-13 12:19:06,225 [DEBUG]  @connection.py:203 - Response status: 400
2011-08-13 12:19:06,225 [ERROR]  @managercli.py:566 - Problem creating consumer Consumer [id = 8a90f8c631c3a8100131c3f0895806fc, type = ConsumerType [id=8a90f8c631c3a8100131c3a88e7b0001, label=system], getName() = jsefler-onprem-62server.usersys.redhat.com]
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 563, in _do_command
    owner=owner_key, environment=environment_id, keys=self.options.activation_keys)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 407, in registerConsumer
    return self.conn.request_post(url, params)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 240, in request_post
    return self._request("POST", method, params)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 204, in _request
    self.validateResponse(result)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 224, in validateResponse
    raise RestlibException(response['status'], error_msg)
RestlibException: Problem creating consumer Consumer [id = 8a90f8c631c3a8100131c3f0895806fc, type = ConsumerType [id=8a90f8c631c3a8100131c3a88e7b0001, label=system], getName() = jsefler-onprem-62server.usersys.redhat.com]




Version-Release number of selected component (if applicable):

[root@jsefler-onprem-62server ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-0.96.5-1.git.40.7cbb9d1.el6.x86_64
subscription-manager-0.96.5-1.git.40.7cbb9d1.el6.x86_64
subscription-manager-gnome-0.96.5-1.git.40.7cbb9d1.el6.x86_64
[root@jsefler-onprem-62server ~]# rpm -q python-rhsm
python-rhsm-0.96.8-1.git.3.e8aaed9.el6.noarch
Comment 1 John Sefler 2011-08-13 12:27:54 EDT
Here's another attempt to register with a similar traceback when --org is excluded...

[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password
global name 'sanitize' is not defined
[root@jsefler-onprem-62server ~]# 


[root@jsefler-onprem-62server ~]# tail -f /var/log/rhsm/rhsm.log

2011-08-13 12:26:15,365 [INFO]  @connection.py:335 - Using certificate authentication: key = /etc/pki/consumer/key.pem, cert = /etc/pki/consumer/cert.pem, ca = /etc/rhsm/ca/, insecure = False
2011-08-13 12:26:15,366 [DEBUG]  @connection.py:175 - Loading CA PEM certificates from: /etc/rhsm/ca/
2011-08-13 12:26:15,366 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/fakamai-cp1.pem'
2011-08-13 12:26:15,367 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/jsefler-onprem-62candlepin.pem'
2011-08-13 12:26:15,367 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2011-08-13 12:26:15,368 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2011-08-13 12:26:15,369 [WARNING]  @connection.py:368 - Error fetching supported resources, this UEPConnection is likely not usable:
2011-08-13 12:26:15,369 [ERROR]  @connection.py:370 - No such file or directory
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 361, in _load_supported_resources
    resources_list = self.conn.request_get("/")
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 237, in request_get
    return self._request("GET", method)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 178, in _request
    context.load_cert(self.cert_file, keyfile=self.key_file)
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Context.py", line 76, in load_cert
    m2.ssl_ctx_use_cert(self.ctx, certfile)
SSLError: No such file or directory
2011-08-13 12:26:15,370 [INFO]  @connection.py:347 - Connection Established: host: jsefler-onprem-62candlepin.usersys.redhat.com, port: 8443, handler: /candlepin
2011-08-13 12:26:15,448 [INFO]  @connection.py:324 - Using basic authentication as: testuser1
2011-08-13 12:26:15,449 [DEBUG]  @connection.py:175 - Loading CA PEM certificates from: /etc/rhsm/ca/
2011-08-13 12:26:15,449 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/fakamai-cp1.pem'
2011-08-13 12:26:15,450 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/jsefler-onprem-62candlepin.pem'
2011-08-13 12:26:15,450 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/redhat-uep.pem'
2011-08-13 12:26:15,451 [DEBUG]  @connection.py:160 - Loading CA certificate: '/etc/rhsm/ca/candlepin-stage.pem'
2011-08-13 12:26:15,451 [DEBUG]  @connection.py:196 - Making request: GET /candlepin/
2011-08-13 12:26:15,530 [DEBUG]  @connection.py:203 - Response status: 200
2011-08-13 12:26:15,534 [DEBUG]  @connection.py:364 - Server supports the following resources:
2011-08-13 12:26:15,534 [DEBUG]  @connection.py:365 - {'serials': '/serials', 'status': '/status', 'owners': '/owners', 'jobs': '/jobs', 'users': '/users', 'consumers': '/consumers', 'subscriptions': '/subscriptions', 'admin': '/admin', 'consumertypes': '/consumertypes', 'statistics/generate': '/statistics/generate', 'content': '/content', 'pools': '/pools', 'products': '/products', 'activation_keys': '/activation_keys', 'atom': '/atom', 'entitlements': '/entitlements', 'events': '/events', 'crl': '/crl', 'rules': '/rules'}
2011-08-13 12:26:15,534 [INFO]  @connection.py:347 - Connection Established: host: jsefler-onprem-62candlepin.usersys.redhat.com, port: 8443, handler: /candlepin
2011-08-13 12:26:15,535 [ERROR]  @managercli.py:62 - Error during registration: global name 'sanitize' is not defined
2011-08-13 12:26:15,535 [ERROR]  @managercli.py:63 - global name 'sanitize' is not defined
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 556, in _do_command
    owner_key = self._determine_owner_key(admin_cp)
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 611, in _determine_owner_key
    owners = cp.getOwnerList(self.username)
  File "/usr/lib/python2.6/site-packages/rhsm/connection.py", line 448, in getOwnerList
    method = '/users/%s/owners' % sanitize(username)
NameError: global name 'sanitize' is not defined
Comment 3 Chris Duryee 2011-08-15 09:38:13 EDT
Fixed as part of a different issue that cwelton found (I don't have a BZ for that one, sorry).

d42033a9821c2ddaad23d31b58cff5b786c5d318, python-rhsm master 0.96.9+
Comment 5 Devan Goodwin 2011-08-15 10:39:40 EDT
Reverted the recent patch that was causing registration to fail because too many product certs were on the system. As of git master 6cb4383e037f7ccd610a89e4250f9270467e9a32 registration should work again.
Comment 6 J.C. Molet 2011-08-16 11:13:12 EDT
This is fixed, all register attempts behave as normal.

subscription-manager-0.96.5-1.git.50.eeb90f1.el6.x86_64
subscription-manager-firstboot-0.96.5-1.git.50.eeb90f1.el6.x86_64
python-rhsm-0.96.8-1.git.5.d42033a.el6.noarch
subscription-manager-gnome-0.96.5-1.git.50.eeb90f1.el6.x86_64

Moving to VERIFIED.
Comment 7 errata-xmlrpc 2011-12-06 12:23:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.