Bug 730513 - [abrt] bash-4.2.10-4.fc15: run_pending_traps: Process /bin/bash was killed by signal 11 (SIGSEGV)
Summary: [abrt] bash-4.2.10-4.fc15: run_pending_traps: Process /bin/bash was killed by...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ec71fde790a9cffe3b168ca22cd...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-14 02:57 UTC by Lester
Modified: 2014-01-13 00:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-16 13:28:13 UTC


Attachments (Terms of Use)
File: backtrace (909.57 KB, text/plain)
2011-08-14 02:58 UTC, Lester
no flags Details

Description Lester 2011-08-14 02:57:52 UTC
abrt version: 2.0.3
architecture:   x86_64
backtrace_rating: 4
cmdline:        /bin/bash
comment:        I had just installed the Intel compiler suite, sourced the script to set the environment variables, and done a cd.
component:      bash
crash_function: run_pending_traps
executable:     /bin/bash
kernel:         2.6.40-4.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        bash-4.2.10-4.fc15
reason:         Process /bin/bash was killed by signal 11 (SIGSEGV)
time:           Sat Aug 13 22:28:57 2011
uid:            500
username:       lester
var_log_messages: Aug 13 22:28:57 morgoth abrt[30758]: saved core dump of pid 2353 (/bin/bash) to /var/spool/abrt/ccpp-2011-08-13-22:28:57-2353.new/coredump (23756800 bytes)

backtrace:      Text file, 931400 bytes

dso_list:
:/lib64/libgcc_s-4.6.0-20110603.so.1 libgcc-4.6.0-10.fc15.x86_64 (Fedora Project) 1313028515
:/lib64/libdl-2.14.so glibc-2.14-5.x86_64 (Fedora Project) 1313028525
:/bin/bash bash-4.2.10-4.fc15.x86_64 (Fedora Project) 1309049256
:/lib64/ld-2.14.so glibc-2.14-5.x86_64 (Fedora Project) 1313028525
:/usr/lib64/gconv/gconv-modules.cache glibc-2.14-5.x86_64 (Fedora Project) 1313028525
:/lib64/libnss_files-2.14.so glibc-2.14-5.x86_64 (Fedora Project) 1313028525
:/lib64/libc-2.14.so glibc-2.14-5.x86_64 (Fedora Project) 1313028525
:/usr/lib/locale/locale-archive glibc-common-2.14-5.x86_64 (Fedora Project) 1313028521
:/lib64/libtinfo.so.5.8 ncurses-libs-5.8-2.20110319.fc15.x86_64 (Fedora Project) 1307148567

environ:
:MOZILLA_NO_ASYNC_DNS=true
:GNOME_KEYRING_CONTROL=/tmp/keyring-kYC1tK
:EDITOR=/usr/local/bin/nedit
:XCURSOR_THEME=#kde_legacy#
:GRACE_EDITOR=/usr/local/bin/nedit
:'FCEDIT=/usr/bin/vi '
:MAIL=/var/spool/mail/lester
:MOZILLA_HOME=/usr/local/netscape
:QTDIR=/usr/lib64/qt-3.3
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:XDG_SESSION_ID=1
:EXPANDER_DIR=/home/lester/.nedit/nedit.util/expander
:GPG_AGENT_INFO=/tmp/gpg-rYzCaQ/S.gpg-agent:2055:1
:ICAROOT=/home/lester/ICAClient/linuxx86
:KDE_SESSION_UID=500
:GR_EDITOR=/usr/local/bin/nedit
:PATH=/home/lester/cmds:/home/lester/bin:/opt/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/sbin:/usr/local/sbin:/sbin:.
:PGPLOT_DIR=/usr/local/lib/pgplot
:INTEL_LICENSE_FILE=/opt/intel/license
:EXPANDER_TPL=/home/lester/.nedit/nedit.util/expander/templates
:GNOME_KEYRING_PID=1866
:ITCL_LIBRARY=/usr/lib/tcl8.5/itcl3.4
:KDE_FULL_SESSION=true
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-yvbBEWXtKH,guid=d854287e3d9b28df9033e46f0000003a
:KDEDIRS=/usr
:SSH_ASKPASS=/usr/bin/ksshaskpass
:QT_PLUGIN_PATH=/home/lester/.kde_fc15/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:HOSTNAME=morgoth.localdomain
:LANGUAGE=
:TMPDIR=/var/tmp/lester.GQhnm4
:XDG_MENU_PREFIX=kde4-
:G_BROKEN_FILENAMES=1
:GS_LIB=
:KDEDIR=/home/lester/.kde_fc15
:SHELL_SESSION_ID=ce7d651b44a640008483fbbf9b61ae28
:'GRACE_PRINT_CMD=lpr -PHP2100PS'
:KDEHOME=/home/lester/.kde_fc15
:XAUTHORITY=/var/tmp/lester.GQhnm4/kde-lester/xauth-500-_0
:KDE_IS_PRELINKED=1
:DESKTOP_SESSION=kde-plasma
:GTK_IM_MODULE=gtk-im-context-simple
:KDE_MULTIHEAD=false
:LANG=en_US.UTF-8
:EXP_DEFINITIONS=/home/lester/.nedit/nedit.util/expander/defs/definitions
:QTINC=/usr/lib64/qt-3.3/include
:XAPPLRESDIR=/home/lester/app-defaults
:SSH_AGENT_PID=1987
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2094,unix/unix:/tmp/.ICE-unix/2094
:KONSOLE_DBUS_SERVICE=:1.53
:LOGNAME=lester
:PWD=/home/lester
:NEDIT_HOME=/home/lester/.nedit
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:SSH_AUTH_SOCK=/tmp/ssh-IizWrQ1868/agent.1868
:WINDOWPATH=1
:EXPANDER_DEF=/home/lester/.nedit/nedit.util/expander/defs
:XDM_MANAGED=method=classic
:HOME=/home/lester
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/lester/.gtkrc-2.0:/home/lester/.gtkrc-2.0-kde4:/home/lester/.kde_fc15/share/config/gtkrc-2.0
:XMODIFIERS=@im=none
:QT_IM_MODULE=xim
:WINDOWID=20971548
:KDE_SESSION_VERSION=4
:QTLIB=/usr/lib64/qt-3.3/lib
:PGPPATH=/home/lester/.pgp
:SHLVL=2
:COLORFGBG=15;0
:MANPATH=/usr/share/man:/usr/local/man:/home/lester/man
:TKDESK=/opt/bin/tkdesk
:DISPLAY=:0
:KONSOLE_DBUS_SESSION=/Sessions/1
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:DM_CONTROL=/var/run/xdmctl
:SHELL=/bin/bash
:PGPLOT_DEV=/xwin
:XDG_RUNTIME_DIR=/run/user/lester
:IMSETTINGS_MODULE=none
:XDG_SESSION_COOKIE=e4dedf6b6d196843aa4b427900000015-1313285590.353444-1314000319
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/lester/.gtkrc::/home/lester/.kde_fc15/share/config/gtkrc
:PROFILEHOME=
:LD_LIBRARY_PATH=/usr/local/lib/pgplot:/usr/local/lib
:PCAL_DIR=/home/lester/.pcal
:HISTSIZE=1000
:TERM=xterm
:USER=lester
:HISTCONTROL=ignoredups

maps:
:00400000-004d9000 r-xp 00000000 08:18 1052589                            /bin/bash
:006d8000-006e2000 rw-p 000d8000 08:18 1052589                            /bin/bash
:006e2000-006e7000 rw-p 00000000 00:00 0 
:008e1000-008ea000 rw-p 000e1000 08:18 1052589                            /bin/bash
:019d2000-02844000 rw-p 00000000 00:00 0                                  [heap]
:33c9200000-33c921f000 r-xp 00000000 08:18 3014702                        /lib64/ld-2.14.so
:33c941e000-33c941f000 r--p 0001e000 08:18 3014702                        /lib64/ld-2.14.so
:33c941f000-33c9420000 rw-p 0001f000 08:18 3014702                        /lib64/ld-2.14.so
:33c9420000-33c9421000 rw-p 00000000 00:00 0 
:33c9600000-33c978f000 r-xp 00000000 08:18 3014715                        /lib64/libc-2.14.so
:33c978f000-33c998f000 ---p 0018f000 08:18 3014715                        /lib64/libc-2.14.so
:33c998f000-33c9993000 r--p 0018f000 08:18 3014715                        /lib64/libc-2.14.so
:33c9993000-33c9994000 rw-p 00193000 08:18 3014715                        /lib64/libc-2.14.so
:33c9994000-33c999a000 rw-p 00000000 00:00 0 
:33c9e00000-33c9e02000 r-xp 00000000 08:18 3014782                        /lib64/libdl-2.14.so
:33c9e02000-33ca002000 ---p 00002000 08:18 3014782                        /lib64/libdl-2.14.so
:33ca002000-33ca003000 r--p 00002000 08:18 3014782                        /lib64/libdl-2.14.so
:33ca003000-33ca004000 rw-p 00003000 08:18 3014782                        /lib64/libdl-2.14.so
:33ca600000-33ca615000 r-xp 00000000 08:18 3022935                        /lib64/libgcc_s-4.6.0-20110603.so.1
:33ca615000-33ca814000 ---p 00015000 08:18 3022935                        /lib64/libgcc_s-4.6.0-20110603.so.1
:33ca814000-33ca815000 rw-p 00014000 08:18 3022935                        /lib64/libgcc_s-4.6.0-20110603.so.1
:33d9c00000-33d9c23000 r-xp 00000000 08:18 3022961                        /lib64/libtinfo.so.5.8
:33d9c23000-33d9e22000 ---p 00023000 08:18 3022961                        /lib64/libtinfo.so.5.8
:33d9e22000-33d9e27000 rw-p 00022000 08:18 3022961                        /lib64/libtinfo.so.5.8
:7faf06085000-7faf06091000 r-xp 00000000 08:18 3014803                    /lib64/libnss_files-2.14.so
:7faf06091000-7faf06290000 ---p 0000c000 08:18 3014803                    /lib64/libnss_files-2.14.so
:7faf06290000-7faf06291000 r--p 0000b000 08:18 3014803                    /lib64/libnss_files-2.14.so
:7faf06291000-7faf06292000 rw-p 0000c000 08:18 3014803                    /lib64/libnss_files-2.14.so
:7faf06292000-7faf0c6b5000 r--p 00000000 08:18 941136                     /usr/lib/locale/locale-archive
:7faf0c6b5000-7faf0c6b9000 rw-p 00000000 00:00 0 
:7faf0c6e3000-7faf0c6e4000 rw-p 00000000 00:00 0 
:7faf0c6e4000-7faf0c6eb000 r--s 00000000 08:18 928110                     /usr/lib64/gconv/gconv-modules.cache
:7faf0c6eb000-7faf0c6ec000 rw-p 00000000 00:00 0 
:7fffa1cb0000-7fffa24af000 rw-p 00000000 00:00 0                          [stack]
:7fffa25ff000-7fffa2600000 r-xp 00000000 00:00 0                          [vdso]
:ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]

Comment 1 Lester 2011-08-14 02:58:18 UTC
Created attachment 518169 [details]
File: backtrace

Comment 2 Roman Rakus 2011-08-15 13:33:31 UTC
Looks like infinite loop - recursively calling shell function. Is it 100% reproducible for you? Where I can get Intel compiler suite?

Comment 3 Lester 2011-08-16 00:46:55 UTC
(In reply to comment #2)
> Looks like infinite loop - recursively calling shell function. Is it 100%
> reproducible for you? Where I can get Intel compiler suite?

This appears to have been a 1 time crash.  I haven't had a problem since logging out and logging back in.  The Intel compiler suite is available for non-commercial use at <http://software.intel.com/en-us/articles/non-commercial-software-development/>.  I installed the full x86_64 suite, which takes awhile to download.

Comment 4 Roman Rakus 2011-08-16 13:28:13 UTC
ok, thanks... I can't reproduce it also. Feel free to reopen when you will have some additional info; how to reproduce for example.


Note You need to log in before you can comment on or make changes to this bug.