Bug 730572 - [abrt] telepathy-butterfly-0.5.15-3.fc15: service.py:571:add_to_connection:KeyError: "Can't register the object-path handler for '/org/freedesktop/Telepathy/Connection/butterfly/msn/eduardo_40tarifadetaxi_2ecom/RosterChannel/List/subscribe': there is alre
Summary: [abrt] telepathy-butterfly-0.5.15-3.fc15: service.py:571:add_to_connection:Ke...
Keywords:
Status: CLOSED DUPLICATE of bug 691209
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:38335e56671649930b48f5fe423...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-14 15:08 UTC by Eduardo Habkost
Modified: 2011-11-20 14:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-20 14:36:56 UTC


Attachments (Terms of Use)

Description Eduardo Habkost 2011-08-14 15:08:08 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        /usr/bin/python /usr/libexec/telepathy-butterfly
comment:        I don't know how it was triggered. Laptop was suspended, I restored it from suspend and probably Empathy was reconnecting to the IM networks.
component:      telepathy-butterfly
executable:     /usr/libexec/telepathy-butterfly
kernel:         2.6.40-4.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        telepathy-butterfly-0.5.15-3.fc15
reason:         service.py:571:add_to_connection:KeyError: "Can't register the object-path handler for '/org/freedesktop/Telepathy/Connection/butterfly/msn/eduardo_40tarifadetaxi_2ecom/RosterChannel/List/subscribe': there is already a handler"
time:           Sun Aug 14 08:04:41 2011
uid:            500
username:       ehabkost

backtrace:
:service.py:571:add_to_connection:KeyError: "Can't register the object-path handler for '/org/freedesktop/Telepathy/Connection/butterfly/msn/eduardo_40XXXXXXXXXXXX_2ecom/RosterChannel/List/subscribe': there is already a handler"
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 442, in state_changed
:    self._state = ClientState.SYNCHRONIZED
:  File "/usr/lib/python2.7/site-packages/papyon/client.py", line 319, in fset
:    self._dispatch("on_client_state_changed", state)
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 44, in _dispatch
:    if event_handler._dispatch_event(name, *args):
:  File "/usr/lib/python2.7/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
:    handler(*params)
:  File "/usr/lib/python2.7/site-packages/butterfly/connection.py", line 346, in on_client_state_changed
:    self._channel_manager.channel_for_props(props, signal=True)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/channelmanager.py", line 125, in channel_for_props
:    return self.create_channel_for_props(props, signal, **args)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/channelmanager.py", line 110, in create_channel_for_props
:    props, **args)
:  File "/usr/lib/python2.7/site-packages/butterfly/channel_manager.py", line 105, in _get_list_channel
:    self, handle, props)
:  File "/usr/lib/python2.7/site-packages/butterfly/channel/contact_list.py", line 114, in ButterflyContactListChannelFactory
:    return channel_class(connection, manager, props)
:  File "/usr/lib/python2.7/site-packages/butterfly/channel/contact_list.py", line 203, in __init__
:    object_path='RosterChannel/List/subscribe')
:  File "/usr/lib/python2.7/site-packages/butterfly/channel/contact_list.py", line 127, in __init__
:    object_path=object_path)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/channel.py", line 147, in __init__
:    object_path=object_path)
:  File "/usr/lib/python2.7/site-packages/telepathy/server/channel.py", line 63, in __init__
:    _Channel.__init__(self, self._conn._name, object_path)
:  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 480, in __init__
:    self.add_to_connection(conn, object_path)
:  File "/usr/lib/python2.7/site-packages/dbus/service.py", line 571, in add_to_connection
:    self._fallback)
:KeyError: "Can't register the object-path handler for '/org/freedesktop/Telepathy/Connection/butterfly/msn/eduardo_40XXXXXXXXXXXX_2ecom/RosterChannel/List/subscribe': there is already a handler"
:
:Local variables in innermost frame:
:path: '/org/freedesktop/Telepathy/Connection/butterfly/msn/eduardo_40XXXXXXXXXXXX_2ecom/RosterChannel/List/subscribe'
:connection: <dbus._dbus.SessionBus (session) at 0x1757e30>
:self: <butterfly.channel.contact_list.ButterflySubscribeListChannel at 0x19451d0>

Comment 1 Eduardo Habkost 2011-08-14 15:08:29 UTC
Package: telepathy-butterfly-0.5.15-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I don't know how it was triggered. Laptop was suspended, I restored it from suspend and probably Empathy was reconnecting to the IM networks.

Comment 2 Brian Pepple 2011-11-20 14:36:56 UTC

*** This bug has been marked as a duplicate of bug 691209 ***


Note You need to log in before you can comment on or make changes to this bug.