Bug 730600 - Bugfix: Check stdoutWatch before removing the handler.
Summary: Bugfix: Check stdoutWatch before removing the handler.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 03:10 UTC by Daniel Veillard
Modified: 2011-12-06 11:26 UTC (History)
4 users (show)

Fixed In Version: libvirt-0.9.4-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:26:35 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Daniel Veillard 2011-08-15 03:10:05 UTC
Description of problem: correct a file descriptor allocation bug reported and
fixed upstream ed009313b166da9fd077758a21aa9a328209e7f1

@@ -95,7 +95,7 @@ virConsoleShutdown(virConsolePtr con)
         virStreamFree(con->st);
     if (con->stdinWatch != -1)
         virEventRemoveHandle(con->stdinWatch);
-    if (con->stdinWatch != -1)
+    if (con->stdoutWatch != -1)
         virEventRemoveHandle(con->stdoutWatch);
     con->stdinWatch = -1;
     con->stdoutWatch = -1;



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 Alex Jia 2011-08-16 06:59:31 UTC
Libvirt indeed should check stdoutWatch before removing the handler, I can see this fix in libvirt-0.9.4-4.el6.src.rpm and current libvirt upstream:

# git show ed009313b166da9fd077758a21aa9a328209e7f1
commit ed009313b166da9fd077758a21aa9a328209e7f1
Author: Juerg Haefliger <juerg.haefliger@hp.com>
Date:   Wed Aug 10 17:03:23 2011 +0200

    Bugfix: Check stdoutWatch before removing the handler.

diff --git a/tools/console.c b/tools/console.c
index 11087e5..171ebc9 100644
--- a/tools/console.c
+++ b/tools/console.c
@@ -95,7 +95,7 @@ virConsoleShutdown(virConsolePtr con)
         virStreamFree(con->st);
     if (con->stdinWatch != -1)
         virEventRemoveHandle(con->stdinWatch);
-    if (con->stdinWatch != -1)
+    if (con->stdoutWatch != -1)
         virEventRemoveHandle(con->stdoutWatch);
     con->stdinWatch = -1;
     con->stdoutWatch = -1;

Hence, change the bug status to VERIFIED.

Comment 4 errata-xmlrpc 2011-12-06 11:26:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.