Bug 730650 - cio_ignore not included in installation initramdisk
Summary: cio_ignore not included in installation initramdisk
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.1
Hardware: s390x
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-08-15 08:56 UTC by Jan Stodola
Modified: 2011-12-06 10:40 UTC (History)
0 users

Fixed In Version: anaconda-13.21.128-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:40:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1565 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-12-06 00:39:12 UTC

Description Jan Stodola 2011-08-15 08:56:21 UTC
Description of problem:
When trying to manually configure devices in linuxrc, clearing device blacklist fails with error:

Scanning for available network devices... 
Autodetection found 0 devices. 
Note: There is a device blacklist active! (Clearing might take long)
c) clear blacklist, m) manual config, r) rescan, s) shell: 
c
Clearing device blacklist... 
/init: line 484: cio_ignore: command not found 
Device blacklist could not be cleared 
/init: line 491: nettable: bad array subscript 

The cio_ignore command is not included in the installation initramdisk:
[root@rtt1 62]# find | grep cio
./sbin/zfcp_cio_free
./sbin/znet_cio_free
./sbin/device_cio_free
./sbin/dasd_cio_free
./modules/2.6.32-184.el6.s390x/kernel/drivers/s390/cio
./modules/2.6.32-184.el6.s390x/kernel/drivers/s390/cio/chsc_sch.ko.gz
./modules/2.6.32-184.el6.s390x/kernel/drivers/s390/cio/qdio.ko.gz
./modules/2.6.32-184.el6.s390x/kernel/drivers/s390/cio/ccwgroup.ko.gz

Version-Release number of selected component (if applicable):
anaconda-13.21.127-1.el6
RHEL6.2-20110815.n.0

How reproducible:
always

Steps to Reproduce:
1. do NOT use CMS config file
2. make sure that "cio_ignore=all,!0.0.0009" is included in parameter file
3. start the installation in the 3270 console
4. when asked, select "c" to clear blacklist
  
Actual results:
Clearing device blacklist... 
/init: line 484: cio_ignore: command not found 

Expected results:
cio_ignore included in initrd, blacklist is cleared in linuxrc

Comment 1 David Cantrell 2011-08-15 15:33:34 UTC
Easy:

diff --git a/scripts/mk-images b/scripts/mk-images
index a23ead3..20804ce 100755
--- a/scripts/mk-images
+++ b/scripts/mk-images
@@ -695,6 +695,7 @@ makeinitrd() {
         )
         instbin $IMGPATH /usr/sbin/dasdfmt $MBD_DIR /sbin/dasdfmt
         cp -a $IMGPATH/usr/sbin/*_cio_free $MBD_DIR/sbin
+        instbin $IMGPATH /usr/sbin/cio_ignore $MBD_DIR /sbin/cio_ignore
     fi
     instbin $IMGPATH ${LIBEXECBINDIR##$IMGPATH}/auditd $MBD_DIR /sbin/auditd

Comment 2 RHEL Product and Program Management 2011-08-15 15:49:44 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 5 Jan Stodola 2011-08-29 08:44:54 UTC
Tested on build RHEL6.2-20110823.1 using anaconda-13.21.134-1.el6.
cio_ignore is present in the intall initrd:
...
c) clear blacklist, m) manual config, r) rescan, s) shell: 
s
Enter 'exit' at the shell prompt to get back to the installation dialog. 
bash: cannot set terminal process group (-1): Inappropriate ioctl for device
bash: no job control in this shell 
bash-4.1# type cio_ignore
cio_ignore is /bin/cio_ignore 
bash-4.1# ls -l /bin/cio_ignore
-rwxr-xr-x 1 root root 15608 Aug 24 02:36 /bin/cio_ignore 
bash-4.1# cio_ignore -R
bash-4.1# INFO kernel:qeth: loading core functions 
INFO kernel:vmur: z/VM virtual unit record device driver loaded. 
INFO kernel:ctcm: CTCM driver initialized 
INFO kernel:lcs: Loading LCS driver  
bash-4.1# 

Moving to VERIFIED

Comment 6 errata-xmlrpc 2011-12-06 10:40:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html


Note You need to log in before you can comment on or make changes to this bug.