Bug 730669 - jython-2.5.2 is available
Summary: jython-2.5.2 is available
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: jython
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 654754 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 10:20 UTC by Upstream Release Monitoring
Modified: 2014-06-12 14:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-12 09:04:48 UTC


Attachments (Terms of Use)
New version of fetch-jython.sh (639 bytes, application/x-shellscript)
2014-02-20 15:11 UTC, Jerry James
no flags Details

Description Upstream Release Monitoring 2011-08-15 10:20:24 UTC
Latest upstream release: 2.5.2
Current version in Fedora Rawhide: 2.2.1
URL: http://sourceforge.net/projects/jython/files/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring

Comment 1 Alexander Kurtakov 2012-05-03 11:13:46 UTC
*** Bug 654754 has been marked as a duplicate of this bug. ***

Comment 2 Tomas Radej 2012-12-13 17:58:01 UTC
I am working on updating Jython to version 2.7.0 alpha2, but I am having significant difficulties with getting the thing to work (unbundling, internal changes in java stack etc.).

Comment 3 Tomas Radej 2013-04-22 08:07:29 UTC
Update: Jython still depends on PyXML (which was removed from Fedora). I'll try talking to upstream to convert to Python's internal xml module.

Comment 4 Jerry James 2014-02-19 20:50:41 UTC
I'm attempting to package a project (jReality) that depends on jython.  I don't know what the minimum version it needs is, but it bundles 2.5.3.  Attempting to build with the current Fedora version results in a failed build due to undefined symbols.

I'm motivated to help move this forward.  What can I do to help out?

Comment 5 Tomas Radej 2014-02-20 12:41:18 UTC
Hi. Since Jython was so badly broken when I tried to repair it a year ago, I let it slide out of my field of view, sorry for not changing the bug status back to NEW. 

Please, talk to the package owner, Alex Kurtakov (akurtako@redhat.com), about updating this package. I can't tell you much now, as I moved away from Java a while ago and I'd have to get back into the loop, which is unfortunately currently impossible for me time-wise. The only thing I remember is that there is an old branch in dist git that Andrew Overholt made in order to attempt to convert Jython to 2.5.2 RC3.

In the meantime, I'm releasing this bug (but I'll stay on CC).

Comment 6 Jerry James 2014-02-20 15:11:52 UTC
Created attachment 865567 [details]
New version of fetch-jython.sh

Thanks for the information, Tomas.  Here is one thing I can do to help.  I'm attaching a new version of fetch-jython.sh to build tar balls out of the new Mercurial repository instead of the defunct subversion repository.

Comment 7 Alexander Kurtakov 2014-02-20 15:18:08 UTC
Thanks Jerry,
I'll try to look at it tomorrow to see what's current state and will write here.

Comment 8 Alexander Kurtakov 2014-03-06 19:27:34 UTC
fetch script pushed with a bit of delay. Let's see when next action will be.

Comment 9 Alexander Kurtakov 2014-06-12 09:04:48 UTC
http://koji.fedoraproject.org/koji/buildinfo?buildID=533771 is in rawhide now.

Comment 10 Jerry James 2014-06-12 14:11:01 UTC
Fantastic!  Thank you very much for the work you put into this.

Comment 11 Alexander Kurtakov 2014-06-12 14:16:46 UTC
(In reply to Jerry James from comment #10)
> Fantastic!  Thank you very much for the work you put into this.

All credit goes to Mat Booth who did it alone.


Note You need to log in before you can comment on or make changes to this bug.