Bug 730671 - incorrect usb.ids path in lsusb man-page
Summary: incorrect usb.ids path in lsusb man-page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: usbutils
Version: 6.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: WANG Chao
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-15 10:29 UTC by WANG Chao
Modified: 2015-02-08 21:42 UTC (History)
4 users (show)

Fixed In Version: 003-4.el6
Doc Type: Bug Fix
Doc Text:
The FILES item in the lsusb(8) manual page displayed an incorrect path to the usb.ids file. This path has been changed to the correct /usr/share/hwdata/usb.ids path.
Clone Of:
Environment:
Last Closed: 2011-12-06 16:18:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1646 normal SHIPPED_LIVE usbutils bug fix and enhancement update 2011-12-06 00:50:34 UTC

Description WANG Chao 2011-08-15 10:29:28 UTC
Description of problem:
Wrong file for lsusb man-page
when you man lsusb
you see:
FILES
       /usr/share/usb.ids
              A list of all known USB ID’s (vendors, products, classes, subclasses and protocols).
(which /usr/share/usb.ids actually doesn't exit)

Version-Release number of selected component (if applicable):
usbutils-003-2.el6

How reproducible:
100%


Steps to Reproduce:
1.man lsusb
2.keep pressing j until you see the FILES section
3.
  
Actual results:
/usr/share/usb.ids

Expected results:
I believe /usr/share/hwdata/usb.ids is what we need. 

Additional info:

Comment 1 Lukáš Nykrýn 2011-09-15 10:18:18 UTC
fix committed to cvs -> http://post-office.corp.redhat.com/archives/cvs-commits-list/2011-September/msg03859.html -> modified

Comment 3 WANG Chao 2011-09-19 05:07:35 UTC
Verify in version 003-4
# man lsusb
...
FILES
       /usr/share/hwdata/usb.ids
              A list of all known USB ID’s (vendors, products, classes, subclasses and protocols).
...

Change this bug status to verified.

Comment 4 Eliska Slobodova 2011-09-19 15:03:38 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The FILES item in the lsusb(8) manual page displayed an incorrect path to the usb.ids file. This path has been changed to the correct /usr/share/hwdata/usb.ids path.

Comment 5 errata-xmlrpc 2011-12-06 16:18:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1646.html


Note You need to log in before you can comment on or make changes to this bug.