Bug 730693 - edge-case memory leak in ares_parse_a_reply
Summary: edge-case memory leak in ares_parse_a_reply
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: c-ares
Version: 6.2
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Hrozek
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 750334
TreeView+ depends on / blocked
 
Reported: 2011-08-15 11:51 UTC by Jakub Hrozek
Modified: 2012-06-20 14:27 UTC (History)
3 users (show)

Fixed In Version: c-ares-1.7.0-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 14:27:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0922 normal SHIPPED_LIVE c-ares bug fix update 2012-06-19 20:46:10 UTC

Description Jakub Hrozek 2011-08-15 11:51:13 UTC
Description of problem:
In very rare cases ares_parse_a_reply can leak memory

Version-Release number of selected component (if applicable):
1.7.0-5

Steps to Reproduce:
1. ares_query to for hostname that only resolves to an AAAA record
2. try to decode the reply with ares_parse_a_reply
  
Actual results:
leaked memory

Expected results:
all memory freed

Additional info:
This was fixed upstream in bffd67f16a8f42fe6dbf79ab2e39d92eea05c8a6

Comment 2 RHEL Product and Program Management 2011-08-15 12:07:56 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 6 errata-xmlrpc 2012-06-20 14:27:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0922.html


Note You need to log in before you can comment on or make changes to this bug.