Bug 730719 - spice-xpi plugin crashes if it's "show()" method is called right after page load
Summary: spice-xpi plugin crashes if it's "show()" method is called right after page load
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-xpi
Version: 6.2
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Arnon Gilboa
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-15 13:55 UTC by David Jaša
Modified: 2012-02-02 09:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-02 09:56:56 UTC


Attachments (Terms of Use)
There was impropred call order in embedded object. (1.84 KB, patch)
2011-09-01 13:07 UTC, Peter Hatina
no flags Details | Diff

Description David Jaša 2011-08-15 13:55:06 UTC
Description of problem:
SSIA.

Version-Release number of selected component (if applicable):
spice-xpi-2.4-4.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. load test.html page that is included in spice-xpi sources
2. hit 'Show' button
3.
  
Actual results:
spice-xpi crashes

Expected results:
spice-xpi returns some error code and continues to run

Additional info:

Comment 1 Peter Hatina 2011-09-01 13:07:57 UTC
Created attachment 521010 [details]
There was impropred call order in embedded object.

Segfault happened due to non existing external controller. Now it should be fixed.


Note You need to log in before you can comment on or make changes to this bug.