Bug 730724 - Discrepancy with SWAP field description on top man page
Discrepancy with SWAP field description on top man page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: procps (Show other bugs)
5.4
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Jaromír Cápík
Martin Kyral
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-15 10:24 EDT by Aaron Ogburn
Modified: 2016-01-31 20:55 EST (History)
7 users (show)

See Also:
Fixed In Version: procps-3.2.7-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 02:32:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 237633 None None None Never

  None (edit)
Description Aaron Ogburn 2011-08-15 10:24:03 EDT
Description of problem:

SWAP is described as "The swapped out portion of a task's total virtual memory image".  This isn't the best description as it may lead one to expect the value of SWAP represents the amount of actual swap space the process is using as reported by other commands such as 'free -m'.  This isn't the case however.  Could this description be improved to prevent this misconception?


Steps to Reproduce:
1. man top
2. /SWAP
Comment 1 Peter Schiffer 2011-10-19 06:44:18 EDT
top man page is part of the procps package, so changing to the correct component
Comment 3 RHEL Product and Program Management 2012-04-19 09:27:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Jaromír Cápík 2012-07-03 09:40:23 EDT
Hello Aaron.

I'm changing the description to match the latest procps-ng upstream manual.

------------------------------------------------------
SWAP
The non-resident portion of a task's address space.
------------------------------------------------------

If you have any other suggestions, then let me know.

Thank you.

Regards,
Jaromir.
Comment 8 errata-xmlrpc 2013-01-08 02:32:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0062.html

Note You need to log in before you can comment on or make changes to this bug.