Bug 73074 - nanny crashing when no load_monitor specified
nanny crashing when no load_monitor specified
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: piranha (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McLean
Brian Brock
:
Depends On:
Blocks: 131576
  Show dependency treegraph
 
Reported: 2002-08-30 08:47 EDT by Sébastien BONNET
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 16:38:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch assigning default load_monitor (rup) after initialization and after getopt stuff (1.69 KB, patch)
2002-08-30 08:50 EDT, Sébastien BONNET
no flags Details | Diff
change default load command to none (530 bytes, patch)
2004-09-01 15:56 EDT, Mike McLean
no flags Details | Diff

  None (edit)
Description Sébastien BONNET 2002-08-30 08:47:03 EDT
Description of Problem:
nanny crashes just after the initialization when the config file does not 
specify any load_monitor.

Version-Release number of selected component (if applicable):
0.7.0

How Reproducible:
Anytime. Edit your lvs.cf file and remove all load_monitor.
Watch out nanny processes (or logs) and noticed than nannies are spawned very 
often.

Actual Results:
As nanny crashes, lvs/fos thinks the realserver is down and thus takes 
inappropriate mesures.

Expected Results:
nanny should stay alive
Comment 1 Sébastien BONNET 2002-08-30 08:50:35 EDT
Created attachment 73945 [details]
Patch assigning default load_monitor (rup) after initialization and after getopt stuff
Comment 4 Mike McLean 2004-09-01 15:56:05 EDT
Created attachment 103366 [details]
change default load command to none
Comment 5 Mike McLean 2004-09-01 16:00:42 EDT
"rup" isn't really a good default since it will cause this problem if
things aren't set up just right.
Comment 8 John Flanagan 2004-12-13 16:23:54 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-469.html
Comment 9 John Flanagan 2004-12-20 20:26:14 EST
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-470.html

Note You need to log in before you can comment on or make changes to this bug.