Bug 730877 - [WHQL] job of "Ethernet - NDISTest 6.5" failed on win7/win2k8 on WLK1.6 (statistics)
Summary: [WHQL] job of "Ethernet - NDISTest 6.5" failed on win7/win2k8 on WLK1.6 (stat...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Yan Vugenfirer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 05:15 UTC by Sibiao Luo
Modified: 2014-07-11 06:49 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No Documentation needed. It is a WHQL problem, covered by MS ERRATA.
Clone Of:
Environment:
Last Closed: 2012-06-20 11:57:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0751 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2012-06-19 19:31:22 UTC

Description Sibiao Luo 2011-08-16 05:15:24 UTC
Description of problem:

1)Run whql on WLK1.6 environment and job "Ethernet - NDISTest 6.5" failed on win7-64 with following tasklog:
---------------------------------------------------------------------
Title Result 
 Failed 
 Start Test 8/16/2011 12:45:59.531 AM Analyzing statistics on test adapter after test 
Error 8/16/2011 12:45:59.531 AM Packets were dropped, but neither OID_GEN_RCV_NO_BUFFER nor OID_GEN_RCV_ERROR statistics were incremented 
File:    Line: 0 
Error Type:   WIN32 
Error Code:   0x50063 
Error Text:   Error 0x00050063 
End Test 8/16/2011 12:45:59.531 AM Analyzing statistics on test adapter after test 
Result:   Fail 
Repro:   ndistest.exe /logo /auto /client /target:Miniport /tc:{29228A04-3587-44C8-AA4E-BA463B531931} /TestEnvInfo:TestEnvInfo.xml /support:{E792FB4B-F83D-498B-AB4E-6F5AFB3ED45D},{EF15889C-7CCC-4BD7-B1CB-DEF034A9FAEF} /msg:{5C254457-8918-4B0C-9C78-F1D8213356B2} /jobgroup:WHQL\Lan /ParaVirtualizationDriver:True
---------------------------------------------------------------------
2)Run whql on WLK1.6 environment and job "Ethernet - NDISTest 6.5" failed on win7-32 and win2k8-32/64/R2 do not have tasklog only have the following errors:
---------------------------------------------------------------------
TaskResult Errors

The Execute Task with Commandline

cmd /c ndistest.exe /logo /auto /server /support:{BFAF978F-A99C-4FB5-A2D3-0C12F6B579DD} /msg:{6F668626-EF77-4780-AD67-AAE8B03CCCA9} /jobs:server.cpp 

Failed with ExitCode e0434f4d
---------------------------------------------------------------------

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-15
kernel-2.6.32-184.el6.x86_64
qemu-kvm-0.12.1.2-2.182.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Start win7-64 guest with rhel5.6 signed qxl driver,following is the CLI:
  # /usr/libexec/qemu-kvm -m 2G -smp 2 -cpu cpu64-rhel6,+x2apic -usbdevice tablet -drive file=win7-64-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private -device virtio-net-pci,netdev=hostnet0,mac=00:11:15:e4:05:35,bus=pci.0,addr=0x4,id=virtio-net-pci0 -netdev tap,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private -device virtio-net-pci,netdev=hostnet1,mac=00:10:15:23:41:c2,bus=pci.0,addr=0x5,id=virtio-net-pci1 -netdev tap,id=hostnet2,script=/etc/qemu-ifup -device e1000,netdev=hostnet2,mac=00:10:18:31:45:73,bus=pci.0,addr=0x6 -boot c -uuid d5415fa9-cf81-45eb-b0b4-a1b55a00309f -rtc-td-hack -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win7-64-nic1,server,nowait -mon chardev=111a,mode=readline -name win7-64-nic1 -spice disable-ticketing,port=5931 -vga qxl -rtc base=localtime

2.Update the latest virtio-net driver in the guest's Device Manager and install the DTM client.

3.Run the job of "Ethernet - NDISTest 6.5".

Actual results:
The job of "Ethernet - NDISTest 6.5" failed with TaskResult Errors about Root Cause on DTM mentioned in the Description of problem.

Expected results:
The job of "Ethernet - NDISTest 6.5" should pass without any error.

Additional info:

Comment 1 Sibiao Luo 2011-08-16 06:23:03 UTC
Plsease ignore the Description of problem 2) above and Update it as following:
Run whql on WLK1.6 environment and job "Ethernet - NDISTest 6.5" failed on
win7-64(win2k8-32/64/R2 as the same) do not have task log only have the following errors(Start NDISTest Client):
---------------------------------------------------------------------
The Execute Task with Commandline

cmd /c ndistest.exe /logo /auto /client /target:Miniport /tc:{29228A04-3587-44C8-AA4E-BA463B531931} /TestEnvInfo:TestEnvInfo.xml /support:{E792FB4B-F83D-498B-AB4E-6F5AFB3ED45D},{EF15889C-7CCC-4BD7-B1CB-DEF034A9FAEF} /msg:{5C254457-8918-4B0C-9C78-F1D8213356B2} /jobgroup:WHQL\Lan /ParaVirtualizationDriver:True 

Failed with ExitCode 1
---------------------------------------------------------------------

Comment 2 Yan Vugenfirer 2011-08-16 08:03:16 UTC
Please set for each virto-net adapter on both VM "Initial Rx buffers" and "Initial Tx buffers" to the same value (256).

To access those parameters click on the viortio adapter in device manager, go to "Advanced" tab and scroll to appropriate parameter.

Comment 3 Sibiao Luo 2011-08-16 08:29:35 UTC
(In reply to comment #2)
> Please set for each virto-net adapter on both VM "Initial Rx buffers" and
> "Initial Tx buffers" to the same value (256).
> 
> To access those parameters click on the viortio adapter in device manager, go
> to "Advanced" tab and scroll to appropriate parameter.

Yes,Thank. But I had set the "Initial Rx buffers" and "Initial Tx buffers" to the same value (256) during my reproducing.

Comment 4 Yan Vugenfirer 2011-08-16 09:27:06 UTC
Please attach CPK file from this run.

Comment 5 Sibiao Luo 2011-08-17 03:12:03 UTC
Created attachment 518588 [details]
Bug 730877 - CPK file

Hi Yan Vugenfirer,

   I have attached the CPK files for the Bug 730877. So far, I can only provide the CPK files for the win2k8-64bit/win2k8-R2/win7-64bit.

   Best wish.

Comment 6 Mike Cao 2011-09-08 11:31:22 UTC
Created attachment 522094 [details]
win2k8_32_CPK_Files

one more time job failed and can not pass even with MS filters .pls check the CPK files ,thanks

Comment 7 Dor Laor 2011-09-27 09:39:41 UTC
Moving to 6.3. From recent report we understand that this does not happens always and sometimes we do pass. Thus this is not a blocker and can be moved to 6.3

Comment 8 Yan Vugenfirer 2011-10-14 13:08:12 UTC
In order to provide us with ERRATA MS is asking if we had this issues on other guests other than win2k8-R2 and if we do, we need to provide CPK file for each guest.

Comment 9 Min Deng 2011-10-19 08:50:42 UTC
So far,QE only hit the issue once on windows 7 64 bits,the failure cannot be filtered.Please see attachment.

Comment 10 Min Deng 2011-10-19 08:57:08 UTC
(In reply to comment #9)
> So far,QE only hit the issue once on windows 7 64 bits,the failure cannot be
> filtered.Please see attachment.
  The issue isn't always reproducible.

Comment 11 Min Deng 2011-10-19 08:59:15 UTC
Created attachment 528943 [details]
win7-64-cpk

Comment 12 Yan Vugenfirer 2011-10-19 10:46:30 UTC
I cannot see this specific issue in the CPK. 

In any case it is understandable that statistics is not always reproducible.

Comment 14 Yan Vugenfirer 2011-11-29 10:21:36 UTC
Moving to ON_QA.

We received ERRATA from MS regarding this failure: Statistics failure - Filter #: 1970 - Virtual NIC fails Stats test because it does not support dropped packet statistics from the virtual switch.

Need to check that when this failure happens the ERRATA actually works.

Thanks,
Yan.

Comment 15 Mike Cao 2011-12-20 09:38:09 UTC
+ Pass[6369] Fail[0]  -:|:- Ethernet - NDISTest 6.5  [ Infrastructure Logs ]   
- Pass[1] Fail[0]  -:|:- RunJob - CheckAdminPrivilege - Client 
 Pass[1] Fail[0]  -:|:- CheckAdminPrivilege
Verfied with win2k8R2

steps:
1.running job Ethernet-NDISTest6.5
2.use fitler to see whether errata works .


Actual Results:
Log:  NotRequired 
- Pass[1] Fail[0]  -:|:- RunJob - CheckAdminPrivilege - Server 
 Pass[1] Fail[0]  -:|:- CheckAdminPrivilege
Log:  NotRequired 
 Pass[1] Fail[0]  -:|:- RunJob - Copy NDISTest binaries - Client 
 Pass[1] Fail[0]  -:|:- RunJob - Copy NDISTest binaries - Server 
 Pass[1] Fail[0]  -:|:- Transfer TestEnvInfo
Log:  NotRequired 
- Pass[1] Fail[0]  -:|:- RunJob - Auto Set Driver Verifier 
 Pass[1] Fail[0]  -:|:- Enable/Disable Verifier
Log:  Present  [ AutoDV.xml ] 
 Pass[6365] Fail[0]  -:|:- Start NDISTest Client
Log:  Present  [ wttsummary.xml ]  [ Unfiltered Log ] 
Applied Errata 
Issue Description Applied Nodes Applied Errors Filtered Failures 
-[Filter Number:3651 Row:226 ] - Miniport drivers will always hit an error regarding the protocol breakpoint count when the InvalidPackets test unloads. This filters out the error.

 5 of 12754 1 1 
Issue Resolution
This will be fixed in a future version of the WLK 
Expiration Date
This filter expires on 12/01/2012. After that date, this filter will no longer apply and the test must pass without this filter applied. For Errata filters, WHQL reserves the right to change this date without notice.  
Issue Description Applied Nodes Applied Errors Filtered Failures 
+[Filter Number:3976 Row:935 ] - Para-virtualization miniport drivers may not be able to keep statistics for packets dropped in the virtual switch 

 2 of 12754 1 1 


Based on above ,this issue has been fixed ,move to verified.

Comment 16 Vadim Rozenfeld 2012-05-03 09:27:52 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Documentation needed.
It is a WHQL problem, covered by MS ERRATA.

Comment 17 errata-xmlrpc 2012-06-20 11:57:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0751.html


Note You need to log in before you can comment on or make changes to this bug.