Bug 730899 - Kmail will endlessly try to reestablish network connection after suspend
Summary: Kmail will endlessly try to reestablish network connection after suspend
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: 17
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 07:14 UTC by Nikolai Maziashvili
Modified: 2012-09-16 19:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-16 19:41:48 UTC


Attachments (Terms of Use)

Description Nikolai Maziashvili 2011-08-16 07:14:52 UTC
Description of problem:
Kmail is unable to reestablish network connection after laptop is woken up from suspend, or after prolonged network connection lost.

Version-Release number of selected component (if applicable):
kdepim-4.4.11.1-5.fc15.x86_64
kdepim-libs-4.4.11.1-5.fc15.x86_64
kdepimlibs-4.6.5-1.fc15.x86_64
kdepim-runtime-libs-4.4.11.1-1.fc15.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Star Kontact, make sure that Kmail part is set up.
2. While Kontact running suspend laptop
3. after couple of hours wake up laptop
  
Actual results:
Kmail will endlessly try to reconnect to network to fetch emails. After 10 minutes or so messages will pop up telling you that servers couldn't be reached due to connection time out. 

Expected results:


Additional info:

Comment 1 Kevin Kofler 2011-08-16 13:03:22 UTC
If KMail gets "stuck" trying to connect:
1. click on the "up" arrow next to the progress bar at the right end of the status bar,
2. click on the "cancel" buttons in the pop up,
3. click on the "down" arrow which replaced the "up" arrow to close the popup again.

That said, this also annoys me to no end, KMail should give up connecting in finite time. An additional annoyance is that it's using 100% CPU while trying to connect, at least for me. Sadly, I don't know how to fix this. :-(

Comment 2 Kevin Kofler 2011-08-16 13:04:28 UTC
(BTW, I have this happening at seemingly random times, I don't use suspend. But I think this is the same bug.)

Comment 3 Nikolai Maziashvili 2011-08-16 13:39:56 UTC
@Kevin. Workaround you give here doesn't work for me, i have tried it before, but Kmail takes forever to cancel as well. Nothing helps but restarting the application.
And besides, why should i do something at all in this case. I think Kmail should be capable (intelligent enough) of reconnecting and getting my mail without my intervention.
And by the way, this problem really old, can't believe that this wasn't addressed before.

PS
Thunderbird doesn't suffer from this, why should Kmail.

Comment 4 Rex Dieter 2011-08-16 13:58:03 UTC
This is reportedly fixed in kdepim-4.7.x, aka kmail2, but perhaps that's just hearsay.

Comment 5 Nikolai Maziashvili 2011-08-29 10:35:28 UTC
Hi Rex,
I'm running KDE 4.7 (Kmail2) and can confirm that issue is solved.

Comment 6 Nikolai Maziashvili 2011-08-29 18:35:12 UTC
Closing this bug. Updating to Kmail2 should solve this problem.

Comment 7 Nikolai Maziashvili 2012-02-21 07:30:41 UTC
I want to reopen this bug. Issue hasn't been solved in Kmail2 (KDE 4.8).
I'm running F16 with kde 4.8 and still kmail won't reconnect to network after suspend.
I still have to restart the application to get it going.

PS...and thunderbird still doesn't have this problem.

Comment 8 Nikolai Maziashvili 2012-04-22 07:45:45 UTC
Problem got even worth (or maybe less? :)...I see all email in the view, but can't open them until i restart akonadi.
I will open new ticket on this one.

Comment 9 Nikolai Maziashvili 2012-09-16 19:41:48 UTC
Haven't came across this one since running F17/KDE4.8. Closing.


Note You need to log in before you can comment on or make changes to this bug.