Bug 730984 - No sound when running startx from runlevel 3
Summary: No sound when running startx from runlevel 3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 13:13 UTC by Steven Usdansky
Modified: 2018-04-11 18:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-04 00:41:39 UTC


Attachments (Terms of Use)

Description Steven Usdansky 2011-08-16 13:13:39 UTC
Description of problem:
No sound in X when X is started using startx. Sound works properly when started from LXDM. Sound works properly at the console before starting the X session

Version-Release number of selected component (if applicable):
xorg-x11-xinit-1.3.1-1.fc16.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Boot into runlevel 3
2. startx
  
Actual results:
No sound

Expected results:
Login theme I set should play as it does in F15. (Appropriate files are in ~/.config/autostart to do this)

Additional info:
I've seen this behavior before (bug 493961). The problem appears to be the same - a ConsoleKit session is not set when running startx. Deleting the check for $XDG_SESSION_COOKIE (one of the proposed fixes for bug 332781) enabled sound as expected when running X from startx.

Comment 1 Matěj Cepl 2011-08-22 12:59:17 UTC
What's the output of

ck-list-sessions

command, please?

Thank you

Comment 2 Steven Usdansky 2011-08-23 22:27:32 UTC
I reset /etc/X11/xinit/xinit-common to restore the check for $XDG_SESSION_COOKIE and rebooted before providing the requested output. To my surprise, I have sound. Not sure what changed (but I have been updating the system daily).

~$ ck-list-sessions
Session1:
    unix-user = '500'
    realname = 'Steve'
    seat = 'Seat1'
    session-type = ''
    active = FALSE
    x11-display = ''
    x11-display-device = ''
    display-device = '/dev/tty1'
    remote-host-name = ''
    is-local = TRUE
    on-since = '2011-08-23T22:06:56.457989Z'
    login-session-id = '1'
    idle-since-hint = '2011-08-23T22:09:30.726451Z'
Session2:
    unix-user = '500'
    realname = 'Steve'
    seat = 'Seat1'
    session-type = ''
    active = TRUE
    x11-display = ':0'
    x11-display-device = '/dev/tty7'
    display-device = ''
    remote-host-name = ''
    is-local = TRUE
    on-since = '2011-08-23T22:09:05.254801Z'
    login-session-id = '1'

Comment 3 Matěj Cepl 2011-09-04 00:41:39 UTC
Not sure what happened either. Closing for now, but feel free to reopen with additional information if it happens again.

Thank you for helping to make Fedora better!


Note You need to log in before you can comment on or make changes to this bug.