Bug 730999 - Spacewalk clients do not reregister when reinstalling.
Summary: Spacewalk clients do not reregister when reinstalling.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 1.5
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
: 772796 (view as bug list)
Depends On:
Blocks: space16
TreeView+ depends on / blocked
 
Reported: 2011-08-16 14:04 UTC by Gerhard Hagn
Modified: 2012-01-18 09:33 UTC (History)
2 users (show)

Fixed In Version: spacewalk-java-1.6.32-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-22 16:49:07 UTC


Attachments (Terms of Use)

Description Gerhard Hagn 2011-08-16 14:04:50 UTC
Description of problem:

When reinstalling a SW Client, die client does not reconnect to the original system profile although the kickstart profile is set to "Re-connect to exixting system profile"

Version-Release number of selected component (if applicable):
Spacewalk Server 1.4 & 1.5 

How reproducible:
Always

Steps to Reproduce:
1. Create kickstart profile in Spacewalk & set option to "Re-connec to existing system profile"
2. Install / and reinstall Client
  
Actual results:
New system profile is created.

Expected results:
Reinstalled Machine connects to existing System Profile

Additional info:
Problem was introduced in SW 1.4 (1.3 was OK) is in Package spacewalk-java
File /var/lib/rhn/kickstarts/snippets/post_reactivation_key

It appears to be an indentation Problem in the Python Code (File in spacewalk-java-1.3.53-1.el5 works).

Comment 1 Michael Mráka 2011-08-30 12:17:14 UTC
THe issue has been fixed in spacewalk master by
commit e69008c7434d66ee8bcac43c2922a45fec0da9a1
    730999 - fixed bad indentation

Comment 2 Milan Zázrivec 2011-12-22 16:49:07 UTC
Spacewalk 1.6 has been released.

Comment 3 Jan Pazdziora 2012-01-18 09:33:47 UTC
*** Bug 772796 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.