Bug 73105 - Evolution's stray processes make for an annoyance
Evolution's stray processes make for an annoyance
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: evolution (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 16:08 EDT by Hamilton Leeper
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-09 21:53:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hamilton Leeper 2002-08-30 16:08:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
Very frequently evolution either won't shut down properly, or when I click on
the calendar, for example, it won't load, so I quit evolution and it won't
restart until I kill off all the stray processes.  This isn't a whole lot of
trouble for me, but it is very inconvenient for new users, or ones who are
accustomed to the 'polish' of outlook.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Open and close evolution a lot
2. Or, simply use it until a component stops responding
3. Try to restart evolution and it gives you an error, and won't start until you
kill all the evolution processes.
	

Additional info:
Comment 1 Jeremy Katz 2002-09-03 00:15:24 EDT
I don't have a lot of problems with it starting -- what symptoms are you seeing
that cause it not to start/shutdown cleanly?  Note that killev can be used to
kill of processes, but shouldn't ever be needed.
Comment 2 Hamilton Leeper 2002-09-04 00:28:44 EDT
Well, I usually have no trouble, but then something like the calendar will
crash, and I'll close evolution and restart it (but it won't restart, you see) 
The reason is there are still a couple of stray processes since evolution is not
just 1 program but like 4 or maybe 5.  Perhaps if the evolution window is closed
it should kill all instances of evolution still hiding in the background.
Comment 3 Dan Naumov 2003-01-13 07:43:23 EST
This is happening to me as well with RedHat 8.0 and evolution-1.0.8-10 and it is
REALLY annoying. Actually, I've been having this problem since the Redhat 7.2
days (can't remember the Evolution version). What happens to me is that often
after closing and re-opening Evolution, several parts of it (like Inbox or
Trash) are innaccesible. If I have say... Calendar selected and click on the
Inbox, Inbox gets highlighted for a second or so, does not get opened and then
the Calendar is highlighted again (using the Folder Bar). This problem has also
been occuring to me when using Evolution 1.0.5 and some other versions when
running FreeBSD, but actually, it was even worse. However, when I use
evolution-1.0.5-1 from Debian Sarge (aka Testing), this problem never seems to
happen so it seems that the debian folk have patched it for their distro.

I would suggest raising the priority of this bug as it causes a REAL ANNOYANCE,
especially to new users like my girlfriend who recently made the switch to
Linux. She shouldn't be forced to kill stray evolution processes on a regular basis.
Comment 4 Jeremy Katz 2003-02-09 21:53:01 EST
I haven't seen this here under 1.0.x or since upgrading to 1.2.  Since 1.2 has
fairly significant changes across the board, I'm closing assuming it's fixed there.

Note You need to log in before you can comment on or make changes to this bug.