Bug 731132 - Possible deadlock when disconnecting from libvirt
Summary: Possible deadlock when disconnecting from libvirt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 18:59 UTC by Daniel Berrangé
Modified: 2011-12-06 15:07 UTC (History)
5 users (show)

Fixed In Version: virt-viewer-0.4.1-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:07:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1614 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2011-12-06 00:51:05 UTC

Description Daniel Berrangé 2011-08-16 18:59:44 UTC
Description of problem:
Due to an invalid implementation of the libvirt events API, virt-viewer may deadlock when disconnecting from libvirt.

Version-Release number of selected component (if applicable):
virt-viewer-0.4.1-1.el6

How reproducible:
Occasionally

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 zhe peng 2011-08-22 07:38:39 UTC
this bug can reproduce with:
virt-viewer-0.4.1-1.el6
libvirt-0.9.4-2.el6
qemu-kvm-0.12.1.2-2.177.el6

verify with :
virt-viewer-0.4.1-4.el6
libvirt-0.9.4-2.el6
qemu-kvm-0.12.1.2-2.177.el6

step:
 1:create a guest with vnc,and start the guest
 2:use virt-viewer to connect the guest
 #virt-viewer $guest_name --debug
 3:stop libvirt service
 #service libvirtd stop
 4:the virt-viewer still active and with debug info:
.........
** (virt-viewer:847): DEBUG: Dispatch handler 4 9 0x2458be0
** (virt-viewer:847): DEBUG: Remove handle 1 4
** (virt-viewer:847): DEBUG: Cleanup of handle 0x2458b70

same behavior when using spice.the bug fixed.
verification passed.

Comment 4 errata-xmlrpc 2011-12-06 15:07:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1614.html


Note You need to log in before you can comment on or make changes to this bug.