Bug 731186 - fusermount -u on sshfs mountpoint fails with "Bad address"
Summary: fusermount -u on sshfs mountpoint fails with "Bad address"
Keywords:
Status: CLOSED DUPLICATE of bug 723757
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fuse
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Josef Bacik
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-16 21:11 UTC by Matt Rogers
Modified: 2011-08-17 12:39 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 12:35:48 UTC


Attachments (Terms of Use)

Description Matt Rogers 2011-08-16 21:11:15 UTC
Description of problem:
With fuse 2.8.3-3.el6_1, trying to unmount an sshfs mountpoint using 'fusermount -u /mnt/point' results in the error "fusermount: failed to unmount /mnt/point: Bad address:

Using fuse 2.8.3-1.el6 does not exhibit this behavior.

The current workaround is to either use umount or stay on 2.8.3-1.el6

Version-Release number of selected component (if applicable):
fuse-2.8.3-3.el6_1

How reproducible:

1. Mount sshfs:

# sshfs 10.12.53.162:/media /mnt/fuse/
root@10.12.53.162's password: 

# mount | grep fuse
10.12.53.162:/media on /mnt/fuse type fuse.sshfs (rw,nosuid,nodev,max_read=65536)

2. Unmount

# fusermount -u /mnt/fuse/
fusermount: failed to unmount /mnt/fuse: Bad address

Additional info:

For the sshfs filesystem I'm using fuse-sshfs-2.2-1.el6.rf from rpmfusion.

Comment 1 RHEL Product and Program Management 2011-08-16 21:28:10 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 2 Josef Bacik 2011-08-17 12:35:48 UTC

*** This bug has been marked as a duplicate of bug 723757 ***


Note You need to log in before you can comment on or make changes to this bug.