Bug 731275 - AttributeError: 'NoneType' object has no attribute 'dbMatch'
Summary: AttributeError: 'NoneType' object has no attribute 'dbMatch'
Keywords:
Status: CLOSED DUPLICATE of bug 731260
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:479d42cb69deb90cf54f4605377...
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-08-17 08:48 UTC by Alexander Todorov
Modified: 2011-08-17 08:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 08:59:46 UTC


Attachments (Terms of Use)

Description Alexander Todorov 2011-08-17 08:48:43 UTC
abrt version: 2.0.5
executable:     /mnt/runtime/usr/bin/python
hashmarkername: anaconda
kernel:         2.6.32-188.el6.x86_64
product:        Red Hat Enterprise Linux
reason:         AttributeError: 'NoneType' object has no attribute 'dbMatch'
time:           Wed Aug 17 00:47:24 2011
version:        6.2

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.129 exception report
:Traceback (most recent call first):
:  File "/usr/lib/anaconda/yuminstall.py", line 1158, in simpleDBInstalled
:    mi = self.ts.ts.dbMatch('name', name)
:  File "/usr/lib/anaconda/yuminstall.py", line 1176, in isPackageInstalled
:    installed = self.simpleDBInstalled(name)
:  File "/usr/lib/anaconda/yuminstall.py", line 1857, in doInstall
:    anaconda.id.bootloader.trusted_boot = self.ayum.isPackageInstalled(name="tboot")
:  File "/usr/lib/anaconda/backend.py", line 242, in doInstall
:    return anaconda.backend.doInstall(anaconda)
:  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
:    rc = stepFunc(self.anaconda)
:  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
:    self.moveStep()
:  File "/usr/lib/anaconda/gui.py", line 1390, in nextClicked
:    self.anaconda.dispatch.gotoNext()
:  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
:    self.intf.icw.nextClicked()
:  File "/usr/lib/anaconda/gui.py", line 1411, in handleRenderCallback
:    self.currentWindow.renderCallback()
:AttributeError: 'NoneType' object has no attribute 'dbMatch'

Comment 1 Alexander Todorov 2011-08-17 08:50:29 UTC
Seeing on latest 6.2 nightly automated jobs in Beaker.

Comment 2 Alexander Todorov 2011-08-17 08:59:46 UTC

*** This bug has been marked as a duplicate of bug 731260 ***


Note You need to log in before you can comment on or make changes to this bug.