Bug 731283 - [abrt] (null): SELinux is preventing /sbin/rpcbind from 'unlink' accesses on the sock_file rpcbind.sock.
Summary: [abrt] (null): SELinux is preventing /sbin/rpcbind from 'unlink' accesses on ...
Keywords:
Status: CLOSED DUPLICATE of bug 729963
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b3d96516b003746aea2e6c11c56...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 09:09 UTC by Jiri Moskovcak
Modified: 2015-02-01 22:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 12:40:33 UTC


Attachments (Terms of Use)

Description Jiri Moskovcak 2011-08-17 09:09:05 UTC
abrt version: 2.0.5.89.g735a.dirty
executable:     /usr/bin/python
kernel:         2.6.40-4.fc15.x86_64
reason:         SELinux is preventing /sbin/rpcbind from 'unlink' accesses on the sock_file rpcbind.sock.

description:
:SELinux is preventing /sbin/rpcbind from 'unlink' accesses on the sock_file rpcbind.sock.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that rpcbind should be allowed unlink access on the rpcbind.sock sock_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep rpcbind /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:rpcbind_t:s0
:Target Context                system_u:object_r:var_run_t:s0
:Target Objects                rpcbind.sock [ sock_file ]
:Source                        rpcbind
:Source Path                   /sbin/rpcbind
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           rpcbind-0.2.0-13.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              2.6.40-4.fc15.x86_64 #1 SMP Fri Jul 29 18:46:53
:                              UTC 2011 x86_64 x86_64
:Alert Count                   6
:First Seen                    Mon 15 Aug 2011 09:37:01 AM CEST
:Last Seen                     Wed 17 Aug 2011 10:13:06 AM CEST
:Local ID                      39f58afa-edf0-4d62-ba00-ed6ab751ba46
:
:Raw Audit Messages
:type=AVC msg=audit(1313568786.272:19): avc:  denied  { unlink } for  pid=1332 comm="rpcbind" name="rpcbind.sock" dev=tmpfs ino=15380 scontext=system_u:system_r:rpcbind_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file
:
:
:type=SYSCALL msg=audit(1313568786.272:19): arch=x86_64 syscall=unlink success=yes exit=0 a0=7f2488883d44 a1=7f2488c34516 a2=7fff589cb540 a3=7fff589cb270 items=0 ppid=1 pid=1332 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=rpcbind exe=/sbin/rpcbind subj=system_u:system_r:rpcbind_t:s0 key=(null)
:
:Hash: rpcbind,rpcbind_t,var_run_t,sock_file,unlink
:
:audit2allow
:
:#============= rpcbind_t ==============
:allow rpcbind_t var_run_t:sock_file unlink;
:
:audit2allow -R
:
:#============= rpcbind_t ==============
:allow rpcbind_t var_run_t:sock_file unlink;
:

Comment 1 Daniel Walsh 2011-08-17 12:40:33 UTC

*** This bug has been marked as a duplicate of bug 729963 ***


Note You need to log in before you can comment on or make changes to this bug.