Bug 73130 - Consider adding HP OfficeJet Linux driver
Consider adding HP OfficeJet Linux driver
Status: CLOSED DUPLICATE of bug 64172
Product: Red Hat Raw Hide
Classification: Retired
Component: sane-backends (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
http://hpoj.sourceforge.net
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 19:42 EDT by David Paschal
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-30 19:43:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Paschal 2002-08-30 19:42:58 EDT
(I selected the component "sane-backends" for now, because there doesn't appear
to be a way to discuss packages that aren't currently in the list.)

Description of Problem:
 
Please consider adding version 0.90 of the HP OfficeJet Linux driver
(http://hpoj.sourceforge.net) to future RedHat releases.  (Understandably, you
may want to hold off on this until after the stable RedHat release that appears
imminent.)
 
It would be helpful if the RedHat person(s) responsible for packaging this
software would monitor the hpoj-announce and hpoj-devel mailing lists and
participate as needed in development/support discussions, as individuals from
several other distributions do, to help make sure hpoj works well with your
distribution.  I'm sure several RedHat users on the mailing list will be happy
to review/test hpoj RawHide/beta packages and provide feedback.  Also, feel free
to forward hpoj Bugzilla reports to hpoj-devel, and let it be known if you have
to apply any patches to the software.
 
Note that print queues for locally-connected hpoj-managed devices must be
configured differently from those for traditional single-function printers.  For
lpd queues, one must print to something like
/var/run/ptal-printd/mlc_usb_OfficeJet_G85 rather than /dev[/usb]/lp*.  For
CUPS, one must print via the "ptal" backend
rather than "parallel", "usb", or "file".
 
I should also point out that current sane-backends versions (through 1.0.8 at
least) may end up creating an undesired circular dependency with hpoj due to the
now-deprecated OfficeJet support in the SANE "hp" backend, unless you apply the
patch
http://hpoj.sourceforge.net/download/patches/sane-remove-ptal-support.patch
posted at http://hpoj.sourceforge.net/todo.shtml.  This patch was recently
submitted to the SANE maintainers, so hopefully this won't be a problem after
SANE 1.0.8.
 
Version-Release number of selected component (if applicable):
 
hpoj-0.90
Comment 1 Tim Waugh 2002-09-01 15:55:49 EDT

*** This bug has been marked as a duplicate of 64172 ***

Note You need to log in before you can comment on or make changes to this bug.