Bug 731332 - reboot says: "global name 'mode' is not defined"
Summary: reboot says: "global name 'mode' is not defined"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Guangze Bai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 11:04 UTC by Caspar Zhang
Modified: 2015-02-08 21:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-08 15:44:16 UTC


Attachments (Terms of Use)
proposed patch (545 bytes, patch)
2011-08-17 11:04 UTC, Caspar Zhang
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1436 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-11-08 23:28:41 UTC

Description Caspar Zhang 2011-08-17 11:04:29 UTC
Created attachment 518655 [details]
proposed patch

reboot test give log:

<output>
Test Parameters: OUTPUTFILE=/var/log/v7/runs/1/reboot/output.log DEVICE= TESTSERVER=unknown RUNMODE=normal DEBUG=off UDI=
<output name="initialize">
The system must be restarted for this test
Ready to restart? (y|n) response: y
</output>
Syncing disks
Waiting for low load...
Current load average: 0.93
Done waiting
Error: test raised exception:
global name 'mode' is not defined
copying attachments...
checking directory /var/log/v7/runs/1/reboot
Skipping output.log

which was caused by this piece of codes:

 69         # wait here for reboot
 70         waitTime = 60 #sec
 71         print "Waiting for shutdown..." % mode                                                                                          
 72         time.sleep(waitTime)
 73         print "Error: shutdown took too long" % mode
 74         return False

a proposed patch is attched.

Comment 1 Caspar Zhang 2011-08-17 11:04:45 UTC
This bug occurs in R16

Comment 5 Caspar Zhang 2011-10-21 15:11:50 UTC
This bug doesn't need a TechNote because of:

a) it was discovered in a v7 1.4 intermediate version, and
b) it was discovered by a Red Hat associate only.

Comment 6 errata-xmlrpc 2011-11-08 15:44:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html

Comment 7 errata-xmlrpc 2011-11-08 18:31:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html


Note You need to log in before you can comment on or make changes to this bug.