Bug 731400 - udev doesn't do full environment generation on some xen blk devices
Summary: udev doesn't do full environment generation on some xen blk devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev
Version: 6.1
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-17 14:15 UTC by Katie
Modified: 2011-12-06 16:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 16:27:19 UTC


Attachments (Terms of Use)
Allow /dev/xvdN devices to be probed for metadata. (828 bytes, patch)
2011-08-17 14:15 UTC, Katie
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1649 normal SHIPPED_LIVE udev bug fix and enhancement update 2011-12-06 00:50:29 UTC

Description Katie 2011-08-17 14:15:07 UTC
Created attachment 518688 [details]
Allow /dev/xvdN devices to be probed for metadata.

Description of problem:

Udev fails to run blkid on some Xen block devices.


Version-Release number of selected component (if applicable):

RHEL 6.0 and 6.1


How reproducible:

100%


Steps to Reproduce:

Try and install RHEL6.x from a DVD in the host's physical drive. It boots and starts, but later says it cannot find the repos. This turns out to be because the disk metadata have not been probed during device init -- the environment is missing ID_FS_LABEL, ID_FS_LABEL_ENC and ID_FS_TYPE


We'd like to propose the attached patch be added to udev rules in both the install disk image and also the regular image. This causes the blkid probe to be run on the devices, providing the metadata which the installer then reads.

Comment 3 Harald Hoyer 2011-09-20 10:20:10 UTC
Created attachment 523996 [details]
Proposed patch

Would this patch work for you?

Comment 5 Simon Rowe 2011-10-21 13:18:37 UTC
Yes, this patch now permits installation from physical DVD media.

Comment 7 errata-xmlrpc 2011-12-06 16:27:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1649.html


Note You need to log in before you can comment on or make changes to this bug.