Bug 731502 - Hard coded "Fedora" notification for RHEL6 build
Summary: Hard coded "Fedora" notification for RHEL6 build
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory
Version: 1.0.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
Assignee: Ian McLeod
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 18:53 UTC by William Henry
Modified: 2018-11-28 21:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 20:10:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0588 normal SHIPPED_LIVE new packages: imagefactory 2012-05-15 22:31:27 UTC

Description William Henry 2011-08-17 18:53:56 UTC
Description of problem:

When building a RHEL 6.1 image I noticed thi sin the imagefactory.log file:

"Storing Fedora image at ...."

Someone must have hard coded 'Fedora' ?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 wes hayutin 2011-09-28 16:38:27 UTC
making sure all the bugs are at the right version for future queries

Comment 3 wes hayutin 2011-10-03 17:11:07 UTC
needs retest

Comment 4 Aziza Karol 2011-10-11 05:23:42 UTC
Building a RHEL 6.1 image does not show hardcoded fedora notifications now.

imagefactory.log shows:
2011-10-11 01:05:41,986 DEBUG imgfac.qmfagent.ImageFactoryAgent.ImageFactoryAgent pid(5043) Message: Method called: name = build_image 
 args = {'image': '', 'build': '', 'template': '<template>\n  <name>RHEL_westest01</name>\n  <os>    \n    <name>RHEL-6</name>    \n    <version>1</version>\n    <arch>x86_64</arch>\n    <rootpw>dog8code</rootpw>\n    <install type="url">\n      <url>http://download.devel.redhat.com/released/RHEL-6-Server/6.1/x86_64/os/</url>\n    </install>\n  </os>\n  <description>RHEL61 x86_64 </description>\n</template>\n', 'targets': ['ec2']} 
 handle = <cqmf2.AgentEvent; proxy of <Swig Object of type 'qmf::AgentEvent *' at 0x2232270> > 
 addr = redhat.com:imagefactory:d5f9d22e-d9c7-4c1a-815e-6a9f729f3b33:image_factory 
 subtypes = {} 
 userId = anonymous
2011-10-11 01:05:41,988 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-10-11 01:05:41,992 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-10-11 01:05:42,106 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:05:42,168 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'object_type': 'image', 'uuid': '7e2d9800-b1e0-459b-b272-66a69902c68c'}) for http://localhost:9090/images/7e2d9800-b1e0-459b-b272-66a69902c68c
2011-10-11 01:05:42,221 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:05:42,223 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'image': '7e2d9800-b1e0-459b-b272-66a69902c68c', 'object_type': 'build', 'uuid': 'a9d301a5-8cef-412c-8cda-b620afd29efa'}) for http://localhost:9090/builds/a9d301a5-8cef-412c-8cda-b620afd29efa
2011-10-11 01:05:43,626 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Created Image Warehouse instance http://localhost:9090 - buckets(target_images, templates, icicles, provider_images)
2011-10-11 01:05:43,633 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Found neither a call-time config nor a config file - doing nothing
2011-10-11 01:05:43,641 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Building Linux for non-upload cloud (ec2)
2011-10-11 01:05:43,649 DEBUG imgfac.builders.BaseBuilder.RHEL6_ec2_Builder pid(5043) Message: Storing placeholder object for non upload cloud image
2011-10-11 01:05:43,680 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:05:43,683 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'object_type': 'template', 'uuid': '70a00411-4db0-48b0-b595-b699ada74f0e'}) for http://localhost:9090/templates/70a00411-4db0-48b0-b595-b699ada74f0e
2011-10-11 01:05:43,765 INFO imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Creating a bucket returned status 500.
2011-10-11 01:05:43,790 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:05:43,791 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:05:43,791 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:05:43,792 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:05:43,792 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:05:43,793 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: 0kB of 0kB
2011-10-11 01:05:43,793 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'icicle': 'none', 'uuid': '52ad6f5b-f0a5-4360-87ee-421d34393db4', 'template': '70a00411-4db0-48b0-b595-b699ada74f0e', 'target_parameters': None, 'object_type': 'target_image', 'target': 'ec2', 'build': 'a9d301a5-8cef-412c-8cda-b620afd29efa'}) for http://localhost:9090/target_images/52ad6f5b-f0a5-4360-87ee-421d34393db4
2011-10-11 01:05:44,041 DEBUG imgfac.BuildJob.BuildAdaptor pid(5043) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed percent complete from 0 to 100
2011-10-11 01:05:44,042 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Getting metadata (['latest_unpushed']) from http://localhost:9090/images/7e2d9800-b1e0-459b-b272-66a69902c68c
2011-10-11 01:05:44,044 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Getting metadata (['latest_build']) from http://localhost:9090/images/7e2d9800-b1e0-459b-b272-66a69902c68c
2011-10-11 01:05:44,047 DEBUG imgfac.ImageWarehouse.ImageWarehouse pid(5043) Message: Setting metadata ({'latest_unpushed': 'a9d301a5-8cef-412c-8cda-b620afd29efa'}) for http://localhost:9090/images/7e2d9800-b1e0-459b-b272-66a69902c68c
2011-10-11 01:05:44,049 DEBUG imgfac.BuildJob.BuildAdaptor pid(5043) Message: Raising event with agent handler (<ImageFactoryAgent(Thread-1, initial)>), changed status from NEW to COMPLETED 

verified on:
[root@dell-pe1950-02 rheltempwes]# rpm -qa | grep aeolus
rubygem-actionpack-3.0.9-1.aeolus.el6.noarch
aeolus-conductor-0.5.0-0.20111007200330gite77b251.el6.noarch
rubygem-activerecord-3.0.9-1.aeolus.el6.noarch
rubygem-ZenTest-4.3.3-2.aeolus.el6.noarch
rubygem-actionmailer-3.0.9-1.aeolus.el6.noarch
aeolus-conductor-doc-0.5.0-0.20111007200330gite77b251.el6.noarch
rubygem-activesupport-3.0.9-1.aeolus.el6.noarch
rubygem-arel-2.0.10-0.aeolus.el6.noarch
aeolus-configure-2.2.0-1.20111007151942git26136f2.el6.noarch
rubygem-aeolus-cli-0.1.0-3.20111003133323git9451323.el6.noarch
aeolus-all-0.5.0-0.20111007200330gite77b251.el6.noarch
rubygem-aeolus-image-0.1.0-3.20111003170706git8f23238.el6.noarch
aeolus-conductor-daemons-0.5.0-0.20111007200330gite77b251.el6.noarch
rubygem-rack-mount-0.7.1-3.aeolus.el6.noarch

Comment 6 errata-xmlrpc 2012-05-15 20:10:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0588.html


Note You need to log in before you can comment on or make changes to this bug.