Bug 73158 - Console does not set i18n fon on login properly
Console does not set i18n fon on login properly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-31 08:05 EDT by Milan Kerslager
Modified: 2014-03-16 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-18 14:18:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2002-08-31 08:05:57 EDT
Loaded i18n font is lost on console after logout/login. /sbin/setsysfont solve 
the problem (should be manually run by logged-in user) but isn't ~/.i18n aware.

Tested on Null-7.3.94

How Reproducible:
Set any any non-8859-1 font in /etc/sysconfig/i18n and try to use i18n 
charater. Then logout, login and try again. Console has ASCII charset now.

i18n support is almost unusable at this point because /etc/profile.d/lang.* 
call unicode_start without parameters.

Please fix /etc/profile.d/lang.* to use unicode_start with parameters as 
setsysfont already does:

       unicode_start $SYSFONT $SYSFONTACM

Please fix /sbin/setsysfont to use ~/.i18n as /etc/profile.d/lang.sh already 
does.
Comment 1 Milan Kerslager 2002-08-31 08:22:36 EDT
Hmm, maybe setsysfont is for system use only so ~/.i18n isn't needed. Sorry.

But /etc/profile.d/lang.* should call unicode_start with parameters still.
Comment 2 Bill Nottingham 2002-09-02 00:53:21 EDT
Fixed in CVS, should be in 6.93-1.
Comment 3 Milan Kerslager 2003-01-18 14:18:28 EST
Current RawHide seems to be OK. Thank you.

Note You need to log in before you can comment on or make changes to this bug.