Bug 731584 - exiting the console during output causes subsequent commands to fail
Summary: exiting the console during output causes subsequent commands to fail
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 21:39 UTC by Dave Allan
Modified: 2016-04-26 13:29 UTC (History)
6 users (show)

Fixed In Version: libvirt-0.9.4-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-08 02:50:17 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Dave Allan 2011-08-17 21:39:01 UTC
If I get on the console and execute:

while true ; do echo -n "The quick brown fox jumped over the lazy
dogs.  The quick brown fox jumped over the lazy dogs.  "; done

and exit the console while the output is spraying, I see a
failure:

 the lazy dogs.  The quick brown fox jumped over the lazy dogs.  The
 quick brown fox jumped over t
virsh # console foo
error: failed to get domain 'foo'
error: An error occurred, but the cause is unknown

virsh # console foo
error: failed to get domain 'foo'
error: An error occurred, but the cause is unknown

virsh # console foo
error: failed to get domain 'foo'
error: no call waiting for reply with prog 536903814 vers 1 serial 6

virsh #

0.9.4-4

Comment 3 Dave Allan 2011-08-22 12:36:30 UTC
The domain I was testing was on my local workstation.

Comment 7 Vivian Bian 2011-09-07 10:01:36 UTC
Hi Dave, 
tested with following pkgs , and didn't encounter this bug 
But since we can't reproduce this bug even with the old version .Would you
please help confirm the patch ? 

libvirt-0.9.4-9.el6
qemu-kvm-0.12.1.2-2.185.el6
kernel-2.6.32-193.el6

1. configure guest grub with "console=tty0 console=ttyS0,115200n8" appended in
the kernel command line 
2. configure guest with serial device added 
    <serial type='pty'>
      <source path='/dev/pts/5'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
3. start guest 
4. enter interactive mode of virsh 
   # virsh  
   Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # console test1
Connected to domain test1
Escape character is ^]

perform the while loop in the guest , and then make a connect-disconnect operation . Never met subsequent commands failures .

Comment 8 Dave Allan 2011-09-07 15:13:31 UTC
I was testing using a libvirt that I built myself, so perhaps that's the source of the difference.  This behavior was nearly 100% reproducible for me, so if you've tested it with the latest libvirt and it's not present, I think you can close as WORKSFORME.

Comment 9 Vivian Bian 2011-09-08 02:50:17 UTC
According to comment 8 , close this bug as worksforme . Once this bug is encountered , we'll open it again


Note You need to log in before you can comment on or make changes to this bug.